1

I currently own a Linksys WRT160NL router with DD-WRT v3.0-r29134 std (02/19/16) installed on it. My ISP (French) is Free, and the modem it provides (the Freebox) supports the IPv6 natively. I can verify that by plugging in my computer directly to the Freebox, I get IPv6 (ipv6.whatismyv6.com works, ipv6.google.com works, etc). But I can't manage to get IPv6 to work with my WRT160NL router. I mean that the router is plugged in to the Freebox and my computer is plugged in to the router, but I don't get any IPv6 connection. Also, I know the router "gets" IPv6 because if I SSH into the router, I can do ping ipv6.google.com. I heard that OpenWRT supports IPv6 better than DD-WRT, but I couldn't manage to install it on my router, it kept crashing and requiring to do 30-30-30 reset and send back firmware through TFTP. Also, I've seen a lot of tutorials telling me to use the Hurricane Eletric Tunnel Broker, but isn't for when you only have IPv4 connection? As the router can connect to IPv6 websites, but not the devices plugged on it, the problem must be in the LAN part, but I set up everything correctly according to all the tutorials on the DD-WRT website. What am I missing?

Note: If you want any screenshot of my router configuration, ask me, I'll upload them.

EDIT March 12th: I used the following configuration: dhcp6c.conf

interface eth0 { # external facing interface (WAN)
  send ia-na 1;
  send ia-pd 1;
  request domain-name-servers;
  request domain-name;
  #script "/etc/wide-dhcpv6/dhcp6c-script";
};

id-assoc pd 1 {
  prefix-interface eth1 { #internal facing interface (LAN)
    sla-id 0; # subnet. Combined with ia-pd to configure the subnet for this interface.
    ifid 1; #IP address "postfix". if not set it will use EUI-64 address of the interface. Combined with SLA-ID\d prefix to create full IP address of interface.
    sla-len 8; # prefix bits assigned. Take the prefix size you\re assigned (something like /48 or /56) and subtract it from 64. In my case I was being assigned a /56, so 64-56=8
    };
  };

  id-assoc na 1 {
  # id-assoc for eth1
};

radvd.conf

interface eth1 # LAN interface
{
AdvManagedFlag off; # no DHCPv6 server here.
AdvOtherConfigFlag off; # not even for options.
AdvSendAdvert on;
AdvDefaultPreference high;
AdvLinkMTU 1280;
prefix ::/64 #pick one non-link-local prefix assigned to the interface and start advertising it
{
AdvOnLink on;
AdvAutonomous on;
};
};

Now, I can ping the router's IPv6 address (fe80::22aa:4bff:fec5:1682) from my computer, but I can't ping ipv6.google.com from the router (SSH) anymore. To make ipv6.google.com work again (only for the router), I need to uncheck "Custom Dhcp6c" and "Custom Radvd" in DD-WRT config, but if I do that I can't ping the router IPv6 anymore from my computer.

EDIT March 12th 5 minutes after last edit: I tried to put again the router's IP (fe80::22aa:4bff:fec5:1683) in the "Next Hop" field in my Freebox configuration, now the router (SSH) can ping ipv6.google.com and even wget it, my computer can still ping the router IPv6 (fe80::22aa:4bff:fec5:1682) but still can't ping ipv6.google.com nor any other IPv6 only website. :(

EDIT September 29th: Even after updating to the almost-latest DD-WRT version (which according to some DD-WRT forum posts should have solved the problem), I still can't get IPv6 working through the router.

  • Have you configured your router as a next hop for an IPv6 subnet in the Freebox configuration? – user2313067 Mar 5 '16 at 19:48
  • oh so that's what it's used for... What should I put in the Next Hop field? i.imgur.com/YpghbSO.png – zdimension Mar 5 '16 at 20:18
  • The link-local IPv6 of your router on its interface with the Freebox. You can then distribute the subnet with your router. – user2313067 Mar 5 '16 at 20:24
  • Do you mean the IPv6 address of the router on the Freebox LAN? Like its 192.168.0.X address? – zdimension Mar 5 '16 at 20:29
  • (I mean like its IPv4 192.168.0.X address but in IPv6) – zdimension Mar 5 '16 at 20:36
0

3 years and 10 months later:

DD-WRT’s version of dhcp6–c does not support the ifid statement, as per the SVN sources.

Search that file/the folder for ifid, it's not there.

Compare that to the latest versio of dhcp-c in FreshTomato in Bitbucket

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.