1

I am using Firefox on Windows 10. ON one PC I have it always run in private mode. On another, I periodically clear the history. In either case, when I type in the url box, it still has all the history of urls I have typed before. This is persistent across sessions and reboots.

This does not make it private at all. I am using the following settings for Clearing History

  • Browsing and Download History
  • Form and Search History
  • Cache
  • Flash Cookies
  • DownThemAll History and Queue

I am not clearing

  • Active Logins
  • Cookies (I do this manually)
  • Site Preferences
  • Offline Web Site Data

How can I clear this url cache ?

Note that this is not a duplicate of How can I clear a single site from the cache in Firefox?. Because this history is wiped.

enter image description here

1

Maybe the urls come from your bookmarks and not from the history (which is wiped)?

  • I just tested it and you are correct. – Rohit Gupta Mar 6 '16 at 20:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.