0

I'm running Photoshop CC 2015 on Mac OS X 10.11.

Since upgrading to Photoshop CC 2015 (2015.1.2 20160113.r.355) when I create a new layer it's all white, when I select pixels and press the Delete key the pixels remain white - I'm unable to get transparent pixels. The layer is a "normal" layer, not a Background layer.

I note this happens even when File > New > Background Contents: is explicitly set to Transparent.

Under Preferences > Transparency I have the default settings of Medium Grid Size and Light Grid Colors.

How do I get transparent pixels back?

UPDATE: I'm having the same issue as described here: https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2015-checkerboard-preview-for-transparency-in-thumbnails-and-artboards-are-gone

  • What is the bitness your working in, or Image Mode? I have heard of this problem before , in that case long ago it was because they were in indexed color modes , or greyscale or whatever modes it can be in that do not show/have a transparency layer. – Psycogeek Mar 7 '16 at 4:52
  • @Psycogeek 32-bit RGB mode. I was finally able to get Photoshop CC 2014 installed and it shows the Transparency Grid fine. – Dai Mar 7 '16 at 5:50
1

Ugh.

Apparently this is "by design". Even though Photoshop Preferences retains the Transparency Grid options page, the feature is permanently disabled in the main document view and layer thumbnails, see here: https://forums.adobe.com/thread/1872120

Adobe:

Hey guys,

As I understand it, in our user testing this was the most useful behavior requested by designers. We do plan to make it more configurable in the future.

Regards Pete

aaaaargghhhh

To add insult to injury, the Adobe CC installer doesn't do anything when I instruct it to install Photoshop CC 2014.

Update I fixed the Adobe CC installation issue by deleting my CC OOBE directory.

1

So Photoshop CC 2015 does still in-fact have the Transparency Grid - it's just disabled in "Artboard Mode" - a mode which can be enabled too easily and without realising it.

If you create a new Photoshop document in CC 2015 by File > New > Default Photoshop Size then you'll get a "normal" document, however if you choose anything else in the New Document dialog you'll likely get an "Artboard document".

You can get-out of an artboard document mode by opening the Layer menu and choosing Ungroup Artboards - if you're not in Artboard mode you won't see that option because it's renamed to Ungroup Layers.

0

Additionally, if you are in Artboard mode, there is a dropdown menu in the Properties panel called "Artboard background color" under which you can select "Transparent" rather than "White"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.