One day my Windows 7 Home Premium (64-bit) pc failed to boot. So far I've been unable to fix or even identify the problem, and I'm looking for help diagnosing the issue. I'm uncertain whether it's a configuration, software, or hardware problem.

When I let the machine boot normally, the Windows logo appears, but when it would present the login screen, the machine suddenly reboots. This happens every time.

I can use the UEFI boot menu to explicitly select the Windows Boot Manager (there are actually two identically-named "Windows Boot Managers": one appears to be the regular OS, the other appears to the the Windows Recovery Environment), and I get this screen:

Windows Boot Manager

Windows failed to start.

File: \EFI\Microsoft\Boot\BCD
Status: 0xc000000f
Info: An error occurred while attempting to read the boot configuration data.

This seems to suggest a problem with the BCD store.

I boot into the WRE and let Startup Repair have a shot at it. It fails, and presents these problem details:

Problem Event Name: StartupRepairOffline
Problem Signature 01: 6.1.7600.16385
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: unknown
Problem Signature 04: 21200512
Problem Signature 05: ExternalMedia
Problem Signature 06: 7
Problem Signature 07: NoRootCause
OS Version: 6.1.7601.
Locale ID: 1033

The diagnostic & repair details reports that all of these tests ran successfully, returning error code 0x0 (execution time in parens):

Check for updates          ( 16ms)
System disk test           (  0ms)
Disk failure diagnosis     (187ms)
Disk metadata test         (  0ms)
Target OS test             ( 78ms)
Volume content check       ( 31ms)
Boot manager diagnosis     (  0ms)
System boot log analysis   (  0ms)
Event log diagnosis        ( 16ms)
Internal state check       ( 15ms)

Root cause found:
Startup Repair has tried several times but still cannot determine the cause of the problem.

It's a very long list, and the same tests repeat with no failures, until the very bottom, which reads:

Root cause found:
Unspecified changes to system configuration might have caused the problem.

Repair action: System files integrity check and repair
Result: Failed. Error code = 0x490
Time taken: 128483 ms

I don't believe I've made any changes to system configuration lately; I haven't changed the hardware or updated any drivers, and Windows Update is set to ask my permission before downloading packages.

I've been working on this all weekend. At one point, I lost the WRE on the drive, and had to use the Win7 install DVD to fix the boot loader. So I think it's likely I've already recreated the BCD store. (Although bootrec /scanos still reports 0 windows installations, which is somewhat troubling.)

I assume system files are corrupt in some way, so I investigate. (I'm aware of this other 0x490 SU question, but that question seems to have a different root cause: "Boot configurations is corrupt" + partition table repair).

My primary drive is a 60 GB SSD, using UEFI and GPT. It has three partitions:

Part 1   | System     | 100 MB
Part 2   | Reserved   | 128 MB
Part 3   | Primary    |  59 GB

I've run chkdsk /f on all three without finding anything. I think that rules out a drive failure, so I proceed to actually fix the system files.

But sfc /scannow says there's a system repair pending that requires reboot to finish. This came up earlier, and I believe I've already rolled back the repair via dism /image:D:\ /cleanup-image /revertpendingactions /scratchdir:D:\dism-scratch, which reported success. I've also verified that \Windows\winsxs\pending.xml does not exist on the drive where Windows is installed.

At this point I'm really at a loss. I can boot into Safe Mode w/ Networking, but I can't boot normally even after disabling all services and startup items using msconfig.

One last thing: while I was sitting here typing this (on a macbook), staring at the WRE command prompt, the computer suddenly rebooted. The same thing happened once earlier while working on the machine, but I assumed that I had hit Restart and forgotten. Now I'm not so sure. That kind of failure could be a PSU failure, but I've got a 1000W supply. It could be something overheating, but the WRE doesn't seem very demanding and my tower is filled with fans (and the side is open).

What to try next? Any help is appreciated.

EDIT: final update, since I guess people still find this question.

I never solved the problem. I just did a fresh install on a different drive. This HDD is still sitting on a shelf, 2 years later.

  • The DISM command you ran does not repair corrupt system files
    – Ramhound
    Mar 7, 2016 at 5:00
  • @Ramhound: I know. sfc repairs those files, but sfc won't run if there is a pending operation. The pending operation presumably can't complete because the machine can't boot normally, which is why I tried to clear the pending operation using dism. It appears that wasn't sufficient.
    – Tom
    Mar 7, 2016 at 6:36
  • If you are running SFC within WinRE the. Your syntax isn't correct
    – Ramhound
    Mar 7, 2016 at 11:22
  • @Ramhound: I am running sfc from within the WRE. I don't know what other syntax to use, this is the syntax I've seen in every forum post and SO question I've looked up. If you know the correct syntax, I'm happy to give it a shot. 8)
    – Tom
    Mar 7, 2016 at 16:45
  • How to run SFC offline....mikemstech.blogspot.com/2011/12/…
    – Moab
    Mar 7, 2016 at 21:43


You must log in to answer this question.

Browse other questions tagged .