8

I've been trying to set up my ARM based computer so that it becomes a hotspot and a client at the same time.

However all of the information I've found about such functionality mention the iw command which seems to be crucial for me to solve the problem I'm having.

It does not seem to work properly for me.

When I type iw wlan0 info I get the error message command failed: No such device (-19).

Why is this happening?

I'm on Debian Wheezy.

EDIT: I have a fully functional WiFi dongle connected to the ARM computer. The WiFi dongle is the only connection to my network.

The Wifi dongle is based on RTL8188CUS.

IMPORTANT

I managed to get it to work briefly by doing the following:

Add contrib non-free to the first two sources in /etc/apt/sources.list

Run apt-get update Run apt-get upgrade

Run apt-get install firmware-realtek

Connect wifi dongle

Run iw list, it works now.

Kind of off topic, but related to why I need IW to work, and I'll get back to IW after my explanation

The wifi dongle I have uses an RTL8188CUS chip, and according to RealTek's release notes this chip should support mixed modes as of version 4.0.0_5967.2021201.

By mixed modes I mean Station+Station, Station+AP, Station+P2P.

Note: The mode "Station" is also refered to as "Managed"

I've been trying to figure out how to make this chip use the Station+AP for months now, however, old drivers have been installed on every system I've used and set up, until I found this (which I'm trying now): https://github.com/pvaret/rtl8192cu-fixes

I've found some more resources which I'll try later.

NOW, back to IW;

IW seems to stop working when the wrong drivers are used.

Even though I use the wrong drivers, I still manage to connect the Wifi dongle to any network, but IW no longer recognizes the device.

IWCONFIG works fine, IFCONFIG works fine.

So I believe that the wrong drivers will cause commands such as iw dev to stop working.

Additional information: the module 8192cu is never loaded when following the installation steps in the GITHUB above.

I know, they are not for the same driver, but they should still work for 8188cu according to RealTek.

6
  • I cannot find any reference to a kernel 3.4.90 in debian wheezy, arm architecture or not. It seems like you are using a custom kernel. I am unable to help you further, you will have to find either a newer kernel or the appropriate headers wherever you downloaded the custom kernel. Sorry, this is the end of the line of what I can do. Mar 8, 2016 at 19:09
  • @MariusMatutiae yes, that is correct, I believe it's a custom kernel. One last question: how could compile my own up-to-date kernel?
    – vaid
    Mar 8, 2016 at 19:20
  • Why do you want to compile it yourself? Isn't it better to install a mainline kernel? Mar 8, 2016 at 19:26
  • How can I do that? The CPU is an Allwinner A10, and the debian image I installed was made specifically for this type of CPU and dev board I'm using. Not many people have managed to get Debian to work on this device. What I have right now is the only thing that seems to work. I think this fits in a different discussion. Would you be interested in talking to me and teach me one or two things about linux and the kernel and how I could install a mainline kernel?
    – vaid
    Mar 8, 2016 at 20:47
  • Ignore my question, I've updated my original post.
    – vaid
    Mar 9, 2016 at 3:44

2 Answers 2

1

You need to install wireless_tools

Open a terminal and type the following commands:

aptitude install wireless-tools

Restart network services:

/etc/init.d/networking restart

Update

You need to add interfaces with iw

iw dev wlan0 interface add <name> type <type>

For wired connection:

iw phy phy0 interface add <name> type <type>

There are several modes supported. The modes supported are:

  • monitor

  • managed [also station]

  • wds

  • mesh [also mp]

  • ibss [also adhoc]

Example:

iw phy phy0 interface add moni0 type monitor
iw dev wlan0 interface add wlan0 type station
9
  • It says that wireless-tools is already installed.
    – vaid
    Mar 8, 2016 at 16:27
  • By doing iw dev wlan0 interface add <name> type <type> I just get help information which tries to tell me how to use iw.
    – vaid
    Mar 8, 2016 at 17:06
  • I think that iw doesn't know what physical devices are available somehow.
    – vaid
    Mar 8, 2016 at 17:06
  • Sorry for not being clear. That's exactly how I wrote it. I replaced <name> with wlan0 and <type> with managed because it worked on my other computer which is x86 based.
    – vaid
    Mar 8, 2016 at 17:26
  • Yes, wpa_supplicant is also installed.
    – vaid
    Mar 8, 2016 at 17:35
1

Install the iw package,

 apt-get install iw

then you will have the iw command.

EDIT:

it is pretty obvious at this moment that you have a bug somewhere. You have the following alternatives:

  1. Since you have a very old kernel, 3.4.90 (see here), you may wish to dramatically update your kernel. There are guides to do this all over Google.

  2. you may try to recompile the device driver, in the hope that the bug is there, not in the old version of iw you run. You do this as follows: downloads Linux backports from here, go to the directory where you downloaded the above file, and give these commands:

    sudo apt-get install linux-headers-$(uname -r) build-essential firmware-realtek
    tar xvfz backports-4.4.2-1.tar.gz
    cd backports-4.4.2-1/
    make defconfig-rtlwifi
    make
    sudo make install
    

Reboot, try your iw commands again. If this fails, I can only suggest updating your old kernel: 3.4 was released in May 2012.

11
  • iwconfig works fine. It shows my WiFi device as expected.
    – vaid
    Mar 8, 2016 at 16:31
  • btw, you've been trying to help me with something related to this before @MariusMatutiae. And I still haven't solved it.
    – vaid
    Mar 8, 2016 at 16:32
  • iw is also insatalled. I've reinstalled it as well.
    – vaid
    Mar 8, 2016 at 17:03
  • 1
    Yes. I do everything in root.
    – vaid
    Mar 8, 2016 at 17:12
  • I don't have any other wifi adapter, however, when I connect the wifi adapter that I am using in to my x86 linux computer iw works fine.
    – vaid
    Mar 8, 2016 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.