1

I read some good reviews about this network printer/scanner, and noticed that it can scan to email or FTP. So I made the flawed(?) assumption that the printer would work independently without a software suite / drivers from Brother.

I tried to install it with the kde "Print Settings" front-end to cups. "Print Settings" finds the printer and lists several interfaces - however, I am unable to print anything no matter what configuration (combination of network protocol / printer driver) I use.

I know that I can download a bash script from Brother.com and run it as root - and then the printer is supposed to work with several x86 Linux distributions. However, I'm not comfortable doing that. Actually, I'll rather scrap the printer and get another one that support lpd/ps natively than risk compromising / messing up my system.

So my question is really if anyone have experience with recent Brother network printers and know a cups configuration that works with one of the standard Linux drivers.

I'm using both Debian Testing and Debian Stable on different machines right now. I also want to get the printer to work from a Rasberry Pi - just for the fun of it :)

1

I have looked at the Brother drivers and by the looks of it they have provided binary drivers with somewhat convoluted BUT documented way how to install them. This is not the worst case scenario, the printer may work, but apart from your reservations about running a script as root, it is also fiddly / inconvenient. If you do have the printer on your hands it really might be worth a try. You can also have a look at https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#Brother - where it mentions model similar to yours.

I believe that separate machines are easier to maintain, so I keep a printer and a scanner separate. Xerox (phaser DN6500) approach to providing drivers contrasts a lot with that of Brother. This is a postscript printer, and the rpm package provides only two .ppd files. I simply unarchive the Xerox provided rpm, put the files in the correct place /usr/share/cups/model/ and install via the cups interface. The printer works in network printing mode straight away, quality is good.

I am sorry I could not be of more help with your specific printer, but I hope this helps you to make up your mind about how you will approach this problem.

  • Thanks for the info. I tried the printer links in the arch wiki - and when I pressed "Print test page" the printer display showed that data was received. However, no matter what format (other brother drivers, postscript, pcl) I sent, noting was printed. I don't really understand what's going on here. Do these printers require some kind of fingerprint in the payload to verify that the job was sent from an "approved" diver? I mean, when I send a Postscript payload to "printer_ip/POSTSCRIPT_P1" it should be pretty obvious to the printer what I try to accomplish. – jgaa Mar 8 '16 at 9:07
  • I'd say your best shot is to go with the drivers and exact installation procedure from the brother website. Probably removing what you have installed with apt-get purge. If the Brother driver works satisfactorily from Debian stable, you can share it. I would not dream the driver would work on raspberry. As to trying to troubleshoot why printer is not accepting the postscript etc jobs, imho, that has a very low chance of a good outcome. – r0berts Mar 8 '16 at 9:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.