7

I have arch with KDE plasma on my laptop. Yesterday I tried a second vga screen using a hdmi-vga adaptor (my laptop has only hdmi entry). Everything worked fine, I used the second screen as an extension of the left border of the main one. I then unplugged the cable and turned off my laptop. Today this is the situation after booting:

enter image description here

The black area is not accessible with the pointer or keyboard.

I can't access the settings or do anything else via desktop environment and I don't know how to move in this way with tty.

Is there a way to reset this behavior?

More info: laptop resolution 1920x1080, Secondary screen resolution 1600x1200. I'm now at the library without possibility to attach anything via hdmi...

UPDATE1: I tried to reboot several times, deleted ~/.kde4 folder, restarted plasmashell, reset to default screen settings (using the few pixels available on the screen). Nothing changed.

UPDATE2: Plugging in the hdmi cable (even without monitor) the problem disappears. When I unplug it comes back. No progress so far. Logging in as root does not show this behavior.

SOLUTION:

A solution would be resetting your user's KDE modifications to defaults, to do so open a terminal and type

mv ~/.kde ~/.kde.old

Log off, then log in with the same user. The ~/.kde folder and KDE settings will de recreated to default.

6
  • SOLVED deleting kde home folder for desktop settings. – refex Apr 4 '16 at 15:37
  • I have the same problem; what folder needs to be deleted? – Enkouyami Jul 22 '16 at 4:20
  • After a deleting the ~/.kde folder, and combination of restarting my laptop and disconnecting my 2nd display, and then restoring the ~/.kde folder, I was able to fix it. – Enkouyami Aug 4 '16 at 14:37
  • Enkouyami is right, my commment was not precise, sorry – refex Aug 7 '16 at 3:10
  • Will one of you please post a complete, clear and unambiguous answer as an answer? – Scott Nov 19 '16 at 22:06
4

I’ve had the same problem on openSUSE Leap 42.1, but didn’t want to delete all my desktop settings (and KDE on openSUSE doesn’t have a „.kde“-folder, only “.kde4”, the deletion of which of course didn’t do anything, deleting kde-related things in .config didn’t help either).

Here is what I did to solve the problem without deleting any other settings:

Comparing the contents of ~/.local/share/kscreen/ of my account with that of a new account showed that instead of one file, there were six with names like “2b70a6fd3b2743573dc02a7767a1512d“ and “2b70a6fd3b2743573dc02a7767a1512d_lidOpened“. The contents of the files showed that some of them contained completely wrong resolutions and x/y positions.

With the second screen plugged in via hdmi, I deleted all files in there. KDE immediately recreated one file “2b70a6fd3b2743573dc02a7767a1512d“ which included the correct resolutions and positions for both screens.

After logging out and back in, I could unplug the hdmi and everything works as expected. Still works after rebooting.

2

Toggling projection (FN key + F7 on my laptop) solved it for me.

Decided to contribute this answer as it's easier to to see if toggling projection solves the issue before trying other methods listed here like deleting KDE config.

1

Building on what @PGMario said, on KDE 4.14.22, (Ubuntu 16.10) simply

  1. Deleting:

    ~/.local/share/kscreen/

  2. No need to restart, if you can plug/unplug the screen, otherwise log in again.

Thats it. Then using KDE screen display (open it using kcmshell5 kcm_kscreen) lets you set things up again.

It had in my case old screen settings that probabbly clashed somehow.

0

I assume you tried a reboot. So, maybe you have a Button (mine Laptop has it) where you can change the screen settings. Like this one?

Where you can choose between - only use second screen, dont use second screen or double screens. Maybe this helps (even if there is no second screen ;-) )

1
  • 1
    I have the key but it didn't work.. Thank you anyway – refex Mar 8 '16 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.