2

I have a HP ProBook with Windows 10.

My keyboard just started acting super strange. When I press certain keys (shift, arrow keys, etc.), it acts weird; however, all the letter and number keys work fine.

I went to a laptop repair shop today and they said it seems to be a software problem.

They advised me to install Windows 7 instead of Windows 10 because they thought the keyboard driver in Windows 10 is defect or not compatible with my computer which came with Windows 7 pre-installed.

The weird thing is that it worked for a long time without any problems, but suddenly it stopped working. I had my computer turned off for some days and suddenly, the keyboard was back to normal without any problems. But it lasted only for a couple hours.

I have tried to change keyboard input language, and it seems to change the behavior of the keys; however, it is still not as it is supposed to be.

I have tried reinstalling drivers, but it says that it already has the most up to date drivers installed.

What can I do to find out what's wrong? And what can I do to repair it? Since it seems to not work to simply replace the keyboard, I have really no idea what to do.

I don't have a Windows 7 CD, so I don't know how to downgrade from Windows 10 to Windows 7.

Edit

When I press SHIFT, my computer will automatically go one line down and highlight, so it seems that it presses the down arrow key while it holds the shift button.

If I press right arrow key, the screen rotates just like if I press ALT GR + RIGHT on a normal computer.

If I press CTRL in a browser window, it zooms out, so it indicates that the minus/hyphen key is being pressed.

I have checked on-screen keyboard, and it seems no keys are actually being pressed, so I don't know why it acts like this.

And as previously mentioned, some of the keys' strange behavior change to another strange behavior if I use another keyboard input language.

| improve this question | | | | |
  • Can you elaborate on "strange"? – RJFalconer Mar 8 '16 at 15:25
  • You didn't bother to say what was wrong! – Bort Mar 8 '16 at 15:25
  • Sorry. I will update my question now – Jamgreen Mar 8 '16 at 15:33
  • This is classic Sticky Keys. – Burgi Mar 8 '16 at 15:42
  • Sticky Keys are turned off – Jamgreen Mar 8 '16 at 15:47
2

@Jamgreen: ok I got it it's the graphic driver hotkey enabled. disable the same. If its intel Graphics, right click-> graphics options-> hot key -> disable. same kind of Steps for other graphics driver.

| improve this answer | | | | |
  • Omg. I have lived with this issue for weeks. Thanks man! :-D – Jamgreen Mar 9 '16 at 2:14
  • Now it started doing it again without me doing anything. When I go to Intel(R) Graphics and Media to turn off the Hot Key Functionality, I see that it is already disabled. Can it also be set somewhere else? – Jamgreen Mar 9 '16 at 22:51
1

Try a USB keyboard and also try whether the issue is reproducible. If the issue is not reproducible, disable the laptop keyboard and use the USB.

If the issue is also happening on the USB keyboard check that:

  1. The Windows Speech Recognition is turned off
  2. Sticky Keys is turned off
| improve this answer | | | | |
  • I have tried an external usb keyboard and it produces no issues at all. I just want my laptop keyboard to work again – Jamgreen Mar 8 '16 at 15:37
  • @Jamgreen Then you most likely need a replacement. – Insane Mar 8 '16 at 15:42
  • @Krab.Koyal can you include how to disable Sticky Keys – Burgi Mar 8 '16 at 15:43
1

I'm seeing this on two different Win10 boxes.

I think it's related (somehow) to the April 2018 Windows update.

On one machine whenever you type the letter "d" into an Excel cell, Excel exits (!). This was fixed by reverting to the previous version of Windows.

On another machine, whenever I type "We" into the first line of an email, the "We" turns immediately into "INd".

Pretty strange.

| improve this answer | | | | |
  • Huh. Windows has an Autocorrect feature, found in Windows Settings → Devices → Typing. I wonder if that's related. – Mathieu K. Oct 15 '18 at 12:51
1

Try to install a new language. In my case, for example, the problem didn't get solved until I installed English (United Kingdom) Language although English (United States) was already installed.

| improve this answer | | | | |
0

Happen on both my laptop and desktop. When it happens I click "alt + tab" then click on a program that seems to fix it.

| improve this answer | | | | |
0

maybe its a little late, I started having this issues too. It was a Windows update that was causing this. Uninstalled it and everything back to normal. Hope it helps.

| improve this answer | | | | |
  • 1
    What did you uninstall exactly? – Ramhound Jun 19 '18 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.