0

I just installed Amix' Vimrc and can't figure out how to get rid of the top bar with the file name and the gray bar on the right side of the window

enter image description here

any help is much appreciated.

1
  • 1
    Don't use someone else's vimrc.
    – romainl
    Mar 10, 2016 at 8:44

2 Answers 2

2

That side bar is most likely the 'foldcolumn', and you can get rid of it by doing:

:set foldcolumn=0

If that doesn't work, try:

:sign unplace *

In the interest of completeness in my answer, I will echo what NighttimeDriver50000 said. The top bar is a curses based tab list. Normally that doesn't show up unless you have two or more tabs, but it appears somehow you have set your 'showtabline' option set to 2. You can reset the behavior to default with either of these commands:

:set showtabline=1
:set showtabline&

Or you can always suppress it (I don't recommend this) by doing:

:set showtabline=0

See:

:help 'foldcolumn'
:help 'showtabline'
:help :set-&
:help signs

(Those help commands are typed exactly as you see them, quotes and other symbols included.)

3

I don't know much about Amix' vimrc, but I do know that that top bar looks like a tabline. It usually only shows up when there's more than one tab, but Amix' vimrc must set it to 2 (always show). To shift it back to the default behavior, just put:

set showtabline=1

At the end of your vimrc. I'm not sure what the grey bar is; I'm not super familiar with gvim settings. (I'm assuming gvim since that doesn't look like something you could do with curses.)

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .