1

I am currently working in Excel and Word 2010 on a data table and want to transfer it to word.

Some columns contains long reference which only the first numbers are useful, other columns may contain important information and are plainly displayed. I removed the automatic line return so that full reference number are not entirely displayed. This is what it look like.

When I copy paste my table from excel to word, whatever the kind of copy paste, long reference are always displayed in full, thus removing lot of space for the important information, and also taking biggest line when there is no information. enter image description here

I've tried to resize the column but the text wrapping is still the same.

enter image description here

How do I remove this automatic return to the line in the first column (and only the first column) of the word table ? I want to keep the information but I want it to only be displayed partially like in Excel. I tought about pasting it as a picture but my table is very long and word does not handle multi page pictures well.

  • This question is lacking details needed for anyone to be able to help you. Please add details of what version of Word you are using. Also, a screen shot would be a big help to describe what you are trying to accomplish. If you need more info about asking questions, check out How to Ask in the help center. – CharlieRB Mar 9 '16 at 12:59
  • added the version and screenshots. – were_cat Mar 9 '16 at 14:06
  • It is still somewhat unclear what you want because you state you are copy and pasting from Word to Excel, but show the opposite. Also, if you are talking about the column with the "ref number", it is doing what Word tables do; it is wrapping text to fit it in the table. Since there is a space after the -, Word sees this as a break in the words and moves it to the next line because the next text is a long bunch of xxxxxxxxxxxxxxx. Have you tried resizing the column in the Word table to the size you wish? – CharlieRB Mar 9 '16 at 14:12
  • Removed the confusing word, removed the space to make sur ewe are not talking about word breaks. Added a screenshot of what happen after resizing. – were_cat Mar 10 '16 at 10:56
  • There is no way for that in Word, it doesn't have similar functionality as Excel has. – Máté Juhász Mar 10 '16 at 12:24
1

You can't. Word doesn't have a "Wrap text" option or command in table cells like Excel does.

You can manually adjust the row height of single rows in a Word table by going to:
Table properties -> Row -> Height: xxx "Exact".

But that's not really a practical approach for a large table.

  • Thanks, i am thinking about vb. Do you think it is possible to get the number of lines of text in the 'description' coulmn ? in my last exemple this would be 3,0 and 6. I could add 1 to zeroes and give an exact height based on the number of lines. – were_cat Mar 10 '16 at 13:26
  • @Were_cat: I had thought about this - running a VBA loop over the table rows, calculating the height needed for the "significant" columns, and setting the height accordingly. But this is quite complicated. The best you can probably do is to count the characters, and apply an average multiplicator. It also must be noted: when forcing a smaller height, there is no way to see the hidden text. Unlike in Excel, where you can scroll through the text in a cell. So you might as well truncate your column 1. – Andre Mar 10 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.