I have a spare 500 GB 3.5" internal SATA HDD which I decided to be used as an external HDD. Recently, I bought an 3.5" enclosure (3.5 inch Cavalry EN-CAXM SuperSpeed USB 3.0 enclosure) for this. I am using USB to connect to this to my laptop. For powering, it comes with external power adapter.

The drive shows up in file explorer as a removable disk but upon clicking it, it says:

"Please insert a disc into removable disk". In properties, it shows 0 bytes used and 0 bytes free space.

Running chkdsk says:

"Cannot open volume for direct access"

Changing drive letter in disk management did not help. Also, there seems to be no sound of spinning.

My question is, how do I know what is at fault? The enclosure or the hard disk? The hard disk was attached to a computer which crashed more than a year ago and had not been used since.

More info: Running Windows 10 Pro 64-bit. Also tried in Vista 32-bit and 7 HP 64-bit.

  • Does the HDD work if you connect it by SATA? I am more inclined to blame the external enclosure then the drive at this point, due to the fact, the enclosure is a generic brand. Yes; I consider Cavalry to be a generic brand name.
    – Ramhound
    Mar 9, 2016 at 20:14
  • Multiple CAXM model numbers, which one specifically, do you have?
    – Ramhound
    Mar 9, 2016 at 20:19
  • Sounds like the drive is bad... Have you tried attaching it directly to an embedded SATA port on the mainboard?
    – acejavelin
    Mar 9, 2016 at 20:20
  • @Ramhound I have included the link in my question. The product package says, EN-CAXM Series. There is no other model number. It is similar to [link]cavalrystorage.com/caxm.aspx although the looks are different.
    – lorddrake
    Mar 9, 2016 at 20:41
  • @acejavelin As I have said before, my desktop computer is not working for past one year. It was working than though. I have tried in another laptop but not in any desktop PC. Let me see, if I can check in with some other computer.
    – lorddrake
    Mar 9, 2016 at 20:45

1 Answer 1


If you have another spare 3.5" disk, you could try attaching that to your adapter. If it doesn't work, it's probably the adapter.

If you have a spare SATA cable, you could connect the 3.5" disk via SATA, boot Windows, and see if you can access the drive then. If you can, it's the adapter.

If you have a spare USB memory stick or blank CD, you could put a portable operating system on it (like pen drive ubuntu), wire up the SATA power and data cables to the disk you're trying to test (disconnect them from your main disk for now, if you don't have a spare SATA cable), and boot to your bootable medium. Try to see if you can access the disk from there.

  • I do have SATA-SATA and SATA-eSATA cables. My laptop has eSATA port. So, can I connect my drive (without enclosure) to my laptop using SATA-eSATA interface and powering it by connecting it to the power supply of my desktop computer (For testing purpose only). My desktop computer doesn't boot up (seems, there is some issue with the motherboard) but the power supply seems to be working. So, checking it using portable OS is not possible.
    – lorddrake
    Mar 9, 2016 at 20:59
  • Oh, the computer you're using is a laptop. In that case, yes, you can probably do that; take a look at this and its linked question; it explains separate power supplies for computers.
    – ecube
    Mar 9, 2016 at 21:09
  • I tried connecting the hard drive to my laptop by using SATA-eSATA cable while powering it through my desktop's power supply. It didn't work. I also tried to use it again in the desktop PC (which wasn't working), it seems that there is no way to check it this way because the display is not receiving any video signals from the CPU. So, I guess, it is better for me to return the enclosure.
    – lorddrake
    Mar 12, 2016 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .