0

I've got following problem:

After updating my OwnCloud from 8.2.2 to 9, it maybe crashed my Apache2 Config. So when I try to open myserver.com/owncloud it says:

Not Found

The requested URL /var/www/owncloud/index.php was not found on this server.

Apache/2.4.10 (Debian) Server at myserver.com Port 80

it's confusing because in Apache confs-available / confs-enabled there is a file for owncloud:

Alias /owncloud "/var/www/owncloud/"

<Directory /var/www/owncloud>
    Options +FollowSymLinks
    AllowOverride All

    <IfModule mod_dav.c>
        Dav off
    </IfModule>

    SetEnv HOME /var/www/owncloud
    SetEnv HTTP_HOME /var/www/owncloud
</Directory>

somebody has a solution?

1

FIX:

I fixed it by editing the .htaccess in the /var/www/owncloud directory

Just add

RewriteBase /owncloud

above

 RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

this fixed it for me

See: https://github.com/owncloud/core/pull/23029

0

I confirm that this also happens on fresh installs of OwnCloud 9 on Ubuntu & Debian. Did not have time to troubleshoot this further this week but I suspect something wrong in the .htaccess file in the /var/www/owncloud dir.

Hopefully someone can pinpoint the issue and post it here.

  • See : github.com/owncloud/updater/issues/270 – Joël Dinel Mar 10 '16 at 19:45
  • 2
    OK, this fix works for me. Edit /var/www/owncloud/.htaccess and just below the RewriteEngine on line, add RewriteBase /owncloud. I suspect this will get fixed in a point release of owncloud 9 shortly. – Joël Dinel Mar 10 '16 at 19:47
  • works, line #41 in .htaccess file – macns Mar 26 '16 at 10:02
0

The above fix worked for me. However my upgrade was still in maintenance mode from the upgrade that probably caused this. I had to go edit the config.php to turn off maintenance mode.

$ sudo nano /var/www/owncloud/config/config.php

I also then restarted apache2

$ sudo service apache2 restart

then I could finish the upgrade and all looks well now. Thanks again for the tip!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.