28

I just upgraded to Windows 10 from a German Windows 7 installation. I switched my display language to English (United States) and my region to English (United Kingdom). Now whenever I search for some settings like for example "UAC", the search results will still be in German. UAC search result

Not only that, but the results of some other searches, such as "language" are not even clickable. The only option that can be clicked here is the one without a settings icon. language search result

I already tried removing German completely in the language settings, switched between German and English as my display language several times and also rebuilt the search index. Any solutions before I have to reinstall the OS entirely are appreciated.

7
  • Kind of a long shot, but did you completely blow away the search database prior to rebuilding the index? The file is C:\ProgramData\Microsoft\Search\Data\Applications\Windows\Windows.edb and you will need to disable the indexing service before you're able to delete it.
    – BrianC
    Mar 11, 2016 at 3:59
  • @BrianC I didn't when I first rebuilt it but even doing so now didn't change anything unfortunately. Thanks for the suggestion though
    – Toizi
    Mar 11, 2016 at 11:00
  • Possible duplicate of Change Windows 7/8/10 system language - welcome screen, login, etc
    – DavidPostill
    Mar 11, 2016 at 11:30
  • 2
    I have the same problem afer installing the Windows 10 Anniversary Update, have you fond a working solution by now?
    – bitbonk
    Aug 8, 2016 at 12:44
  • 1
    @bitbonk unfortunately I could not find a solution and after a few days I simply gave up and reinstalled the OS entirely
    – Toizi
    Aug 9, 2016 at 15:31

3 Answers 3

4

I had a similar problem (actually, my entire laptop was in Thai). I did the following steps:

To open Settings, go to the Action Center (the icon in the taskbar beside the clock) and press All Settings.

  1. Go to SettingsTime and RegionRegion and Language → Delete all other languages and only keep English. My keyboard layout was also Thai, so that can be changed here too.

  2. Control PanelRegionFormat → Set it to English

  3. Control PanelRegionLocation → Set it properly

  4. Control PanelRegionAdministrativeChange system locale → Select English

This was the most important step. You may reboot after this.

  1. Control PanelRegionAdministrativeCopy settings → Check both boxes and click OK

Again reboot! After doing all this German should vanish entirely from your laptop. After this, make sure you have deleted German language and selected override English as language everywhere just to be sure.

3
  • Tried this and deleting Windows.edb but the problem is still there, the results still show up in the old language and are not clickable.
    – GGG
    Aug 28, 2016 at 18:52
  • Did you install anniversary update? If not, please do, since my problem of unclickability was solved by it
    – pulsejet
    Aug 29, 2016 at 10:06
  • I'm on version 1607, which I believe is the anniversary update and the problem still persists.
    – GGG
    Aug 30, 2016 at 17:07
2

I just ran into this myself. Try rebuilding the 'index', this is where the start-menu searchresults are stored.

http://www.winbeta.org/news/how-rebuilding-your-search-index-windows-10

1
  • After I rebuild the 'index' the search still appear the wrong language. But I tryed logout cortana first, then rebuild the index, and login into cortana again finally it worked.
    – Evan
    Oct 14, 2017 at 13:09
-2

When you change the language in Windows not all the nooks and crannies of the OS are affected. I haven't run into your problem before, but I would try copying the language setting to other parts of Windows. Here's how.

  1. In the Cortana box type Control Panel.
  2. Select the heading Clock, Language, Region.
  3. Under the Region heading select Change location.
  4. A Wizard dialog will open, click on the Administrative tab and press the Copy Settings button.
  5. On the wizard page fill the two checkboxes at the bottom of the page and click OK.
1
  • Thanks for the answer but I actually did that already since I wanted to change the language for the welcome screen as well but I forgot to mention it in my post
    – Toizi
    Mar 11, 2016 at 10:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.