1

I was trying ubuntu from a bootable pen drive of ubuntu. But Ubuntu was unable to access F: Drive, it was showing the following error message :

Error mounting /dev/sda2 at /media/ubuntu/New Volume: Command-line `mount -t >"ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=999,gid=999,dmask=0077,fmask=0177" >"/dev/sda2" "/media/ubuntu/New Volume"' exited with non-zero exit status 12: >Failed to read last sector (231628799): Invalid argument HINTS: Either the volume is a RAID/LDM but it wasn't setup yet, or it was not setup correctly (e.g. by not using mdadm --build ...) or a wrong device is tried to be mounted, or the partition table is corrupt (partition is smaller than NTFS), or the NTFS boot sector is corrupt (NTFS size is not valid). Failed to mount '/dev/sda2': Invalid argument The device '/dev/sda2' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

On one of the forums I found the following solution

Run the following command in ubuntu terminal sudo ntfsfix /dev/sda2

I did so, but the partition was still inaccessible But error code was different it was Error code 13

The I again logged on to windows, (Windows 7 Ultimate 64 bit) While booting It asked for dskchk and I allowed, then it performed a long operations which included something like following:

Deleting corrupt attribute record (128, "")... and Inserting data attribute into file 36015...

After that 1. The drive size was somehow reduced to 52GB from 110GB 2. Although all files are being shown in the drive but most of the files have become zero size. Some files are ok. 3.The drive have now become accessible from ubuntu but there also the drive size is 52 GB and files are being shown zero bytes size.

What exactly is the problem? If possible, how can I recover my data? If data can not recovered should I format my F drive and will it make it normal ? How to format the drive to restore it to its normal size 110 GB ?

Edit 1: I tried

chkdsk F:/f

command in windows, it did not find any error with drive and also could not repair it.

I tried iRecover tool but it gets stuck after a certain time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.