5

The computer doesn't even have Flash installed yet still gets ads through JW Player. This is really annoying as they have audio. It has Adblock Plus installed but doesn't block JW Player ads, like on this website: http://www.minq.com/fitness/1541/8-reasons-why-europeans-are-healthier-than-americans#page=1

screen shot Here is a screen shot of the ad I'm referring to, circled in red. Since it's a video it moves and have audio. Do other people see it?

This site seems to think JW Player is a virus, but I don't think it is. I'm fine with fully disabling it, if possible.

Also, is there anyway for ABP to be more robust and resilient to sites like http://blockadblock.com/ which break the site if ABP is detected?

8
  • I use ABP in FF and I don't see the adverts you mention.
    – Burgi
    Mar 11, 2016 at 13:20
  • @Burgi you sure? I added a screen shot and circled the ad in red.
    – Celeritas
    Mar 15, 2016 at 6:12
  • Positive. See here: i.stack.imgur.com/T5ld2.png
    – Burgi
    Mar 15, 2016 at 8:40
  • You can rightclick on the advert and select Block this ad to add a manual blocking rule. If you want I can post a tutorial on this.
    – Burgi
    Mar 15, 2016 at 8:46
  • @Burgi when I right click I don't get that option? However I have the element selector ad-on which does allow me to block it. But the question actually is asking how do you block ALL Jw Player, not just select ones.
    – Celeritas
    Mar 16, 2016 at 4:04

7 Answers 7

6

Go to Adblock options, advanced, your filters, add the following-

||jwplayer.com^
||jwcdn.com^
||content.jwplatform.com^

Not sure which one worked, but it seems to work for me.  

1
  • Can confirm this filter also works in uBlock Origin (go to uBlock Origin > Open the dashboard (cogs icon) > My filters). As of today, Firefox still seems unable natively to prevent JWPlayer autoplay, despite having a "block video and audio" privacy setting, and several additional options in about:config, none of which prevents sites (e.g. Techradar) spamming you with video content hosted on JWPlayer.
    – blackworx
    Jan 18, 2021 at 10:41
2

To disable jwplayer in firefox -> Open Firefox -> about:config -> in URL browser Accept the risk, search for media.autoplay.enabled. Change from true to false

0
1

The JW player doesn't show the browser menu. Right-click elsewhere on the page and choose the "Block an ad on this page" option. Then adjust the slider to the right until the JW player is no longer visible. Done!

1
  • This works in Chrome, also.
    – SDsolar
    Nov 11, 2017 at 22:57
0

You can report issues such as "ads not being blocked" through Adblock Plus by clicking on its icon and selecting "Report issue on this page...".

However, in case you do have malware on your computer, Adblock Plus (or other ad blockers) can't help you with this problem. For that you could run Malwarebytes to check for anything suspicious that might inject those ads.

0

jwplayer is just a html5 player, it doesn't install on your computer.

I'm using firefox with ublock, and doesn't see the ads in your link.

-1

just add this line to your adBlock filter


content.jwplatform.com/libraries/*

-1

The uBlock Origin plugin completely blocks JWPlayer. It is similar to AdBlock and ABP.

Firefox: https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/

Chrome: https://chrome.google.com/webstore/detail/ublock-origin/cjpalhdlnbpafiamejdnhcphjbkeiagm

1
  • 1
    which filter? I don't think this works by default in the current version Apr 6, 2020 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.