I've been meaning to ask this question for a long time. While trying to copy/move files(large sizes say over 10GB) in Windows from or to any external drive, I notice that the transfer activity remains homogeneous until 99% where it stops responding for a minutes and then completes the few remaining bytes.

I don't understand the logic behind this as I've noticed it only in Windows and not in Ubuntu. Both internal and external drives are SSDs. It happens with flash drives too. The CPU is a ULV processor, could it be the problem?

Thanks!

  • 1
    Because the % estimate in Windows is not accurate most of the time. – Moab Mar 12 '16 at 3:59
  • 1
    Try disabling your antivirus/antimalware to see if it helps? Maybe the antivirus is checking the files so that's why it is taking too long to finish. – axys93 Mar 12 '16 at 4:06
  • 3
    Also it is a common issue when transferring files from a fast source to a more slower destination. If the external drive is connected via USB, it can diminish the real transfer speed. If the file is very large, the speed goes slowly down to the real transfer speed between the two devices, because new data only can be read in same amount as the old data are removed from buffer. So when reaching the end of the file, it 'pauses' for a moment waiting for the data in buffer be transferred to the target. So the only solution in this case is wait windows transfer the cache content. – axys93 Mar 12 '16 at 4:17
  • @axys93 have tried disabling the antivirus but still the same. about your second comment..yeah it might be the reason – Ashwin Mar 12 '16 at 4:34
up vote 3 down vote accepted

Caching.

(Probably)

When Windows writes to disk it caches the writes to the disk. It shouldn't be doing this for flash or external USB drives, but it's the only real explanation that fits.

The copy file dialogue is showing the speed to copy files at the cache and not the disk itself and is then waiting at the end for all the data to be written out. The copy program can presumably see that there is data in the cache waiting to be written out but not how much.

There is a way to disable the write-cache for drives which may well stop this behaviour.

There is a quick guide to disabling the cache on the disk at Seven Forums, but I'm not at my computer to summarise it properly here. Basically you want to disable the disk cache only on removable or external devices, for performance you want to leave it enabled on internal devices.

You should be able to get to the same properties pages shown in the tutorial I linked by right-clicking the disk in an Explorer window, going down to properties, then selecting the Hardware tab that shows at the top of the window.

It should be a bit like this image from The Windows Club but you should have an option for quick removal on USB devices. (I'll replace this when I am able to later)

enter image description here

  • I just experienced this problem while copying data (> 500GB) from D: to E:. Though your explanation sounds reasonable, the ram appears to be almost completely empty and there is no activity on disk C:. On the other hand, both the disks D: and E: appear to be active (the former is read, the latter is written) at full speed three hours later the 99% figure has been reached. So I am not sure cache or buffering are the real general answer to this windows issue. – Patrick Trentin Jun 20 '17 at 21:41

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.