0

I have set up an hotspot with CoovaChilli and freeRADIUS. Everything is working fine. I get a landing page, after logging in, I am able to access internet.

Now, I have also hosted a web server which is listening at port 3740 in the same system as CoovaChilli and freeRADIUS. I am not able to access that port from any system connected to the hotspot.

My wifi hotspot access point IP is 192.168.10.1 and the webserver is running at port 3740. Even if I login to my hotspot, the port is not accessible. Can you let me know how to open this port?

command

$ netstat -an | grep :3740

output

tcp 0 0 0.0.0.0:3740 :::* LISTEN

  • Is the hotspot in the same network as the webserver? if not, have you the routes setup correctly (as it will probably try to find your webserver by diverting the traffic through the default gateway). Can you access your webserver from another computer in the same network - check you firewall settings on the webserver and from which interfaces it will allow connections) – Zina Mar 12 '16 at 10:52
  • I have set up the hotspot and the webserver in the same network. None of the computers connected in the same network are able to access the webserver. Internally only the webserver is accessible. – muchumanoj Mar 12 '16 at 11:06
  • So the webserver is in the 192.168.10.x/24 (I assume) network. Can you explain what you mean by "Internally only the webserver is accessible"? Can you access the webserver from any network or only from the webserver itself? After rereading your post/comments it looks like a firewall on the webserver issue or the webserver is not listening on all interfaces. Could you edit your Q with the output of netstat -an | grep :3740 or netstat -an | findstr :3740 depending if your webserver is on linux/windows. – Zina Mar 12 '16 at 12:10
  • By Internally, I meant, in the local browser or by the command "wget 192.168.10.1:3740". The output of the command netstat gives me the following: $ netstat -an | grep :3740 ouput: *tcp6 0 0 192.168.10.1:3740 ::: LISTEN ** – muchumanoj Mar 12 '16 at 12:51
  • Please update your Q with the netstat output and firewall settings. – Zina Mar 12 '16 at 12:53
0

I have figured out the solution: I had to change the coovachilli config file to allow the ports

HS_TCP_PORTS="3740"

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.