0

My Windows 10 time is ALWAYS wrong. I've tried:

  • enabling synchronization settings from: Control Panel-> Date & Time -> Internet Time -> Change Settings -> time.windows.com or time.nist.gov. With error message:

An error occurred getting the status of the last synchronization. The RPC serves is unavailable.

  • System file checker tool (sfc /scannow). With result no problem found.

  • Starting Windows Time from Windows Services. With error message:

System error 126 has occurred.

The specified module could not be found.

  • Reregistering w32tm. With SAME error message:

C:>w32tm /debug /disable

C:>w32tm /unregister

W32Time successfully unregistered.

C:>w32tm /register

W32Time successfully registered.

C:>net start w32time

The Windows Time service is starting.

The Windows Time service could not be started.

A system error has occurred.

System error 126 has occurred.

The specified module could not be found.

How to proceed from now on?

1

You might check your registry.

  1. Navigate to the following Registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters

  2. Double click on the TYPE key and remove the extra space after the value.
    Extra spaces entered after the Value are shown as a blue selected text.

  3. Restart the computer.

REF: https://support.microsoft.com/en-us/kb/959113

1
  • Full confession:I'm having and investigating a similar issue and Microsoft's recommendation did nothing for me. – Ragaar Dec 1 '16 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.