On my previous PC (same os, same trackball (Logitech TrackMan Wheel) I was able to middle click tabs in firefox and visual studio to close them (and middle click links in FF to open in new tabs).

I just rebuilt my PC and now this isn't working. I vaguely remember having this problem the last time i rebuilt, but I can't remember what i did to resolve it and my google-fu is failing me.

I've downloaded SetPoint from Logitech and have set the middle button to a bunch of different settings with no luck (Universal Scroll, Generic Button, AutoScroll, Other (Middle Button, Close, Unassigned, Do Nothing).

Any ideas at all?

  • Have you confirmed in Firefox that middle click indeed should open a new tab? Have you tried add-on Tab Mix Plus? – kmarsh Feb 8 '10 at 13:12
  • Yeah, as far as i can tell it <should> open links in new tabs and close tabs when you click them. It's doing neither. Middle click is also not working as it used to in Visual Studio (close a tab). – Rob Feb 8 '10 at 13:24
  • I have a similar problem, my default behavior is changed to "send to background" instead of middle click. I am pretty sure it has something to do with MS IntelliPoint software. But I cannot fix it either. Works fine on Linux. – OliverS Feb 9 '10 at 8:31
  • This is exactly what mine is doing (send to background). Now, interestingly enough, when i change the setpoint software from middle click to close, it closes stuff properly, so I know setpoint is working ... it's just not working for middle click <grumble grumble /> – Rob Feb 10 '10 at 12:11
  • I also tested this in internet explorer, and it also is not closing the tab. – Rob Feb 10 '10 at 12:43

Make sure you have the latest version of SetPoint. You may need to uninstall and reinstall the SetPoint software. By default the middle button will be set to zoom or the application switcher, but you should be able to use SetPoint to configure the middle button as "Other -> Middle Button". Then Firefox will recognize it correctly and close the tab.

Also, the new setpoint software will let you do custom actions for different applications on some mice, so make sure that when you configure it you select the "All Other Programs" or create a special managed program for Firefox.

You may also need to check under the Mouse options in the control panel to see if there are any other configuration issues. If that doesn't work make sure try uninstalling any other mouse software (Microsoft IntelliPoint, uberOptions, Synaptics Touchpad, etc) as well as uninstalling any drivers listed under the "Mice and other pointing devices" in the device manager. Then reboot and it should reinstall the drivers.

Finally if that doesn't work you need to figure out if the problem is in the Mouse, in Set Point, or in the OS. Try this:

  1. Plug in another 3 button mouse that is not made by Logitech and see if the middle button works. If it still doesn't work try using something like Mousekeys to simulate the middle mouse button. If none of these work it may be an OS issue.

  2. Try alternate mapping software such as X-Mouse. Also try mapping the middle click function to another button to see if that work.

  3. Try changing to a different driver. Replacing the existing driver with an older version or with a generic mouse driver might get it to work again. Also try it on another computer and see if works there.

  4. Buy a different mouse :-P Sometimes it is not worth fixing if you can just replace it. I'd highly recommend the MX Revolution, since it has lots of buttons and a nice "free spin" scroll wheel, but it is not a trackball.

  • Had this also, this is the way to go – GHad Feb 9 '10 at 16:33
  • Have the latest version of SetPoint. I do not see an "All Other Programs" option. The middle button is set to "Other -> Middle Button" (as i noted above) and it does not work in either Firefox or Visual Studio 2008. – Rob Feb 10 '10 at 12:09
  • Try using unixpapa.com/js/testmouse.html to test and see what is being registered in the OS. Button 0=Left, 1=Middle, and 2=Right – Greg Bray Feb 10 '10 at 16:23
  • middle click doesn't do anything on that page, right click, left click, double click all work... middle click just sits there.. – Rob Feb 10 '10 at 16:44
  • now, if i set the middle button in setpoint to be a right click it identifies as a right click.. – Rob Feb 10 '10 at 16:48

AHA... I found it. I'm an idiot for not realizing this before... Thanks for everyone that helped.

So... I have a program KatMouse that is wonderful. if you haven't used it, download it not. Basically it allows you to use the scroll wheel in inactive windows. Super helpful if you are debugging stuff, or if you need to scroll a solution whilst typing in another window.

Anywho.. The middle tab on the startup screen has options for the wheel button. All I had to do is choose "none of the buttons" which basically disabled this part of the program. After that.. POOF.. mouse button working as intended. I'll leave it up to the mods to determine which post best directed me to the answer... I suppose it was greg's, but it really wasn't the answer. Either way is fine with me. Marking this one or his.

  • Damn, had the same problem here :) It's an really annoying feature of that app :) – Stormenet Apr 25 '10 at 19:01
  • Only you can mark someone's answer as accepted. You just have to click on the tick. – Joe Taylor Dec 3 '10 at 11:41

SetPoint can have application specific settings. Check if Firefox is in the "All Other Programmes" drop down.

  • I dont see an "All Other Programmes" option in my sitepoint and i made sure it's the most current (Control Center version 4.80.103 Driver Version 4.82.11) – Rob Feb 10 '10 at 12:10
  • @Rob: Ah, it's probably because I have uberOptions installed: uberoptions.net Not sure if that might help you. – Sam Hasler Feb 10 '10 at 12:49
  • uberOptions installed.. still no luck. uberOptions is neat in that it offers tons of different options for my middle button, and they seem to work except for the middle button function itself... maybe it's something other than the mouse options. Not sure where else to look tho.. maybe it's the hook for the OS that isn't sending the right signal to the app? – Rob Feb 10 '10 at 13:25

Check to see if you have VS Productivity Power Tools installed. Then make sure that "Tools > options > productivity power tools > Middle click scrolling" is turned off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.