0

On Windows 8.1 64bit, I am unable to delete non-existing HomeGroup that appears in ControlPanel->HomeGroup, at the same time I am unable to join the same non-existing HomeGroup, what is logical. When asked for pass for joining group windows returns that group does not exists (what is expected).

I tried deleting files from C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\, and stopping HomeGroupProvider service. But files reappears again.

Also I tried all regular tips and tutorials from Microsoft web and similar sites. I removed all 2nd party antivirus and only WindowsDefender is remained.

Is there any solution for this issue? Please help.

1

I think I had the same problem and here is the solution that works for me. Working on Windows 10

WHAT HAPPEND TO ME

I had a homegroup with 3 of my computers connected. Someday I wanted to delete it to get a new fresh one, I went on all my 3 computers and leave the homegroup (the normal way to do that).

After that all of my computer should have to ask me to create a new homegroup, instead they all wanted to join a homegroup (a homegroup that wasn't exist anymore).

I believe Windows forgot to delete some files on the "leaving homegroup" process, and my computers wanted to share a homegroup that they were no longer part of.

SOLUTION

Shut down all your computers, boot a computer and apply these changes before boot another.

  1. Open Task Manager > Services and stop HomeGroupListener and HomeGroupProvider services

  2. Delete the content of C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\

  3. delete the contents of C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys (Use Unlocker if needed to delete the folder, recreate it and set the full autorisations to everyone. Right Clic on the folder > Properties > Security)

  4. open regedit (Windows > search > regedit or Windows+R > regedit)

  5. navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HomeGroupProvider\

  6. delete the contents of ServiceData and LocalUserMembership

  7. navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HomeGroupListener\

  8. delete the contents of ServiceData

  9. reboot

  10. run homegroup troubleshooter a couple of times. (Windows search > Troubleshooter > Network & Internet > Homegroup)

After that, all should be OK.

I don't fully understand all of this changes, I applied answers I found on the web to this problem. Maybe there are steps that may not be required.

NOTE particular to my case

The third computer I wanted to reconnect to my Homegroup was wired via ethernet but not directly to my internet box. (I use 2 little devices to pass my internet signal from my box to my computer, through the electric system of my flat -> Idk the name).

And these boxes was also blocking the connection to the Homegroup, I had to connect this third computer by Wifi to my network to finally get my third computer connected to the Homegroup.

0

try to run services.msc then stop the following services:
peer networking grouping
peer networking identity manager
then delete everything from here C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\

waiting for you reply

3
  • this does not help. all the same.
    – Dragutin
    Mar 13 '16 at 1:36
  • try this may help link Mar 13 '16 at 11:04
  • Helped the procedure with deleting `C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking` directory, on one another computer in network that was previously hosted HomeGroup on same network. Although, this computer that was previously hosted homegroup, has deleted all groups, and on them there was only option to create now one. But I wanted my first mentioned computer to be host.
    – Dragutin
    Mar 13 '16 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.