0

Every time I've installed Windows 7 with my location set as my actual location of Canada, it installs the OS to recognize my keyboard as a french keyboard.

It isn't, of course, but it still takes the input as if it is, and even if I change it and set it to recognize my keyboard as a US keyboard as it is, the next time I start up the system it's back to treating my keyboard as a french one. I've fixed this in the past, but the issue I'm faced with now is beyond that.

  • The time, date, etc. are all in french format, to say 24 hour time, and the days of the week/name of month are complete gibberish to me.

  • Most software I install installs and runs in French. Some software I use is fine as it offers in software settings to change the language, but a lot of it, specifically Deluge, which I use almost on the daily, offers no such setting. I've tried reinstalling, and in these installers setting the install language to English, but never fail, I open the software and it's in french.

  • I've attempted to fix this issue and I don't know the results of my attempts yet, but my keyboard will ALWAYS register as a french keyboard when I start up my system. Even when and if I remove the french keyboard option from the input panel, its back to the french keyboard input setting next time I start up my system.

During the install process I never once selected that I wanted my system to do all of this. The BIOSes run in English, though I don't know if that'd have anything to do with these issues.

I've attempted everything that I can think of to fix these issues except reinstalling my operating system. This is NOT an option.

If anyone might have any idea on how to fix these problems, I'd greatly appreciate it.

2
  1. Change your language preferences in Control Panel => Language (do not bother about displayed setting, this is particular one in mine Windows); change it to whatever fits your circumstances:

Language preference

  1. Change system locale to English (Canada)

Changing system locale

at Control Panel => Region:

CP=>Region

  1. Read How can I change Deluge language? in Windows OS:

There is a bug in the way GTK sets language on Windows but there are several workarounds:

​Set a global LANG environment variable to the language you require, e.g. en. Create a cmd file to set the LANG and open deluge. Copy the following text into notepad:

set lang=en
start "" deluge.exe

Save the file as Deluge.cmd in the same folder as Deluge.exe. Create a shortcut to the .cmd file and use it to start Deluge.

To force the use of English only, delete the following language files from Deluge program folder:

C:\Program Files\Deluge\deluge-1.3.x-py2.x.egg\deluge\i18n
C:\Program Files\Deluge\share\locale
0

Standard way to manage all that stuff:

Control Panel -> Region and Language -> Formats: - here you could change date and time formats.

Control Panel -> Region and Language -> Keyboards and Languages -> Change Keyboards: - here you could add and/or remove input languages and set the default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.