0

I have an issue with sfc /scannow. It finishes the verification process and informs me of errors there were unable to be fixed. I looked into CBS.log file and I found four entries related to drupdate.dll. As I understand, this is related with driver updates over windows update? I'm running Win 10 Pro x64.

AMD A6 5200

4GB DDR3 RAM

SATA 500GB HDD

This is a snippet of that error

2016-03-11 18:44:18, Info                  CSI    00003cfe@2016/3/11:17:44:18.431 Primitive installers committed for repair
2016-03-11 18:44:18, Info                  CSI    00003cff [SR] Verify complete
2016-03-11 18:44:18, Info                  CSI    00003d00 [SR] Verifying 100 (0x0000000000000064) components
2016-03-11 18:44:18, Info                  CSI    00003d01 [SR] Beginning Verify and Repair transaction
2016-03-11 18:44:23, Info                  CSI    00003d02 [SR] Cannot repair member file [l:12]"DrUpdate.dll" of Microsoft-Windows-ServicingStack, version 10.0.10586.113, arch amd64, nonSxS, pkt {l:8 b:31bf3856ad364e35} in the store, file cannot be checked
2016-03-11 18:44:24, Info                  CSI    00003d03@2016/3/11:17:44:24.310 Primitive installers committed for repair

I tried using dism /checkhealth (not the precise command, I don't know it from my head). What else can I do?

I tried asking MS support but they give me useless advice. The reason I used sfc /scannow is because KB3140768 Cumulative update fails to install. Also I tried manually replacing the drupdate.dlls that I have found and they were 1kb in size. I replaced them with the ones from the ISO image of Win 10 and still the same error occurs in sfc.

1

Download the Update KB3139907, use 7zip to extract the MSU. Now use expand.exe to extract the KB3139907.CAB:

expand -F:* C:\Windows10.0-KB3139907-x64.cab C:\Windows10.0-KB3139907-x64

Now run Dism /Online /Cleanup-Image /RestoreHealth /Source:C:\Windows10.0-KB3139907-x64 /LimitAccess to restore the Dll.

| improve this answer | |
  • btw on my question, findstr /c:"[SR]" CBS.log >sfcdetails.txt did not work (question was deleted) – interwebz Mar 14 '16 at 21:37
  • @interwebz your WGA question? what fails? Share the CBS.log so that I can take a look at it. – magicandre1981 Mar 15 '16 at 5:15
  • still says accessdenied. even after i copied the folder to the desktop and used admin cmd to run the above command. FINDSTR: Cannot open CBS.log – interwebz Mar 16 '16 at 2:49
  • @interwebz share the complete folder (onedrive, dropbox, other 1 click hoster) – magicandre1981 Mar 16 '16 at 5:14
  • onedrive.live.com/… – interwebz Mar 20 '16 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.