4

Recently I have completed data migration from Intel i330 120GB SSD to Intel 535 240GB SSD using Intel Data Migration Software. Intel i330 was my first SSD which I also used for data migration from my HDD before that.

After migration I booted SSD and all worked fine after I had to restart system a few times. That was until I had to shutdown laptop which was when I saw the following:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

Insert your Windows installation disc and restart your computer. Choose your language settings, and then click "Next." Click "repair your computer." If you don't have this disc, contact your system administrator or computer manufacturer for assistance.

Status: 0xc000000e

Info: The boot selection failed because a required device is inaccessible.

Photo: enter image description here

Used System Repair Disk that I made from my OS and it did the job and it all worked again until shutdown again. Then I had to repeat procedure with disk only to realize that system partition is found but it still keeps looking for something as progress bar did not stop and let me proceed. I set from Raid to ACHI in BIOS which made SSD disappear so I switched to IDE and then I could proceed past progress bar. It seemed as disk did its job:

Photo: enter image description here

I noticed system partition is D: which is strange as it was supposed to be C: and maybe it's just because I am in recovery environment? I tried to BCDEDIT to set it to C: but was given errors:

Photo: enter image description here

Hoping it would work it did and here's what I see now currently in Windows:

Photo:
enter image description here

I don't know what to expect after I shutdown laptop again but I am trying to prevent this problem in future. Could it be that BIOS somehow keeps boot configuration in its CMOS and disregards what System Repair Disk corrected in bootloader / mgr sector?

UPDATES:

Here's a photo of Windows Disk Management for previous SSD:

enter image description here

And here's a photo for current SSD:

enter image description here

Thanks for help.

1. Attempted to use bcdboot as Tom Yan suggested but saw no output from applied command:

enter image description here

2. /f BIOS Parameter is not implemented in Windows 7 so that's the reason command didn't work first time. It worked without it leaving all prior though and here are a few things that changed in BCD Store:

Before applying command:

enter image description here

After applying command:

enter image description here

For Windows Boot Manager:

  • "path" is now missing
  • "inherit" added
  • "resumeobject" added
  • "toolsdisplayorder" added

For Windows Boot Loader:

  • "description" changed from Windows 7 Enterprise (recovered) to "Windows 7"

I hope this didn't downgrade it to Windows 7 Starter? And there's this "recovered"

  • "inherit" added
  • "recoverysequence" removed
  • "recoveryenabled" removed
  • "resumeobject" details changed
  • "nx" added
  • "detecthal" added

Here are files I have now in H:/Boot

enter image description here

While I don't know what all these added/removed parameters mean, I think that based on "recoverysequence" and "recoveyenabled" removed parameters as well as added backup boot files every time it failed to boot and I had to use recovery CD it temporarily referred to boot settings in backup boot file/s and then reverted to normal boot file after I restarted system. Since it remained unchanged it leads me to think that was the reason behind failed boots and only when I applied bcdboot as was suggested it finally made necessary changes in boot file. I am not sure if it works but will report once I restart.

3. This drives me nuts already. After several resumes from standby and normal work I got BSOD which did not have enough time to capture and after restart I get the following screens, some appeared one after another and others after further restarts:

enter image description here

enter image description here

enter image description here

enter image description here

Here's BCD entries that I see in REGEDIT and one highlighted is "resumeobject" that I see in bcdedit. Could be all other entries cause conflict so they must be deleted?

enter image description here

I had to use System Recovery disk to repair in order to boot the system again. I am going to delete BCD backup files. Maybe it reverts to them which causes error to repeat.

4
  • Do you keep BOTH of the SSDs connected to the system after the migration? Can you paste the output of list volume in diskpart (with the command prompt of the System Repair Disk)? – Tom Yan Mar 14 '16 at 3:50
  • I am in Windows now. Here's the output from CMD > DISKPART: s15.postimg.org/663eyzdh7/diskpart_listvolume.jpg – Boris_yo Mar 14 '16 at 5:43
  • I am only able to see a thumbnail. Can you edit your post and upload a screenshot of Disk Management instead? – Tom Yan Mar 14 '16 at 6:40
  • You should be able to see 666 x 250 px screenshot in that link. I have updated post and included information you requested. – Boris_yo Mar 14 '16 at 7:38
4

Try to re-install a whole new set of bootloader files (bootmgr, BCD Store...) with bcdboot:

bcdboot C:\Windows /s H: /f BIOS

In case for some reason you don't want to use a separate partition for that, you can do this instead:

bcdboot C:\Windows /s C: /f BIOS

Then change the active partition to C::

diskpart
select disk 0
select partition 1
active

Then you can, for example, delete H: and F: after reboot and extend C: til the end of the drive.

Ref.: https://technet.microsoft.com/en-us/library/hh824874.aspx

Caveat:

Using bcdboot to fix your BCD Store will cost you its association to the recovery environment available on your system. That is, you won't be able to create recovery USB drive:

enter image description here

as well as, Reset this PC and most items in Advanced options will be lost when you boot to Troubleshoot with Advanced startup:

enter image description here

15
  • Drive H: serves as a place to keep boot manager. I wondered why system was not setup to keep it on same drive as OS but after learning about BitLocker it was clear that it requires system reserved partition with boot manager for it to work. This drive should stay hidden but it was not. I think I will keep drive H: just to be able to use BitLocker in future. – Boris_yo Mar 14 '16 at 8:22
  • It's up to you, that's not my main point. You can "move out" the boot files with bcdboot just before you implement BitLocker too though. – Tom Yan Mar 14 '16 at 8:28
  • Hi, I have not done this procedure but I am in the process. I see that parameter /s says this "Specifies an optional volume letter parameter to designate the target system partition where boot environment files are copied. The default is the system partition identified by the firmware." What firmware is this? BIOS or SDD? – Boris_yo Mar 25 '16 at 19:18
  • Just updated question. I have attempted your command-line parameters but saw no results. – Boris_yo Mar 25 '16 at 19:29
  • Apparently the bcdboot in Windows 7 does not have the /f switch added yet, so leave out /f BIOS – Tom Yan Mar 25 '16 at 19:31
3
+50

With so many manipulations done to Windows and the boot partition, it will be very hard to diagnose the problem without physical access to the computer.

I would therefore counsel to fix the problem with a big hammer :

  1. sfc /scannow
    Do first to verify system integrity.

  2. Try Paragon Rescue Kit 14 Free Edition
    Rescue Kit is a tool with a collection of rescue wizards.

  3. Repair Install
    This will do an in-place upgrade install of Windows to itself, to fix your currently installed Windows and preserve your user accounts, data, programs, and system drivers. Use a Windows 7 ISO with SP1.

  4. In the worst case, backup the C:\ disk (but not the recovery partitions), reformat the entire disk, install from scratch Windows 7 SP1 from USB or CD, then restore the backup to C:. Use a backup product that can handle the restore to a partition of a slightly different size (Paragon Backup & Recovery 14 Free Edition is supposed to be able to do that).

  5. Another possibility is to repeat the move from the old disk to the new one, but using another tool than Intel Data Migration (such as Paragon).

0

I may not be fully understanding what u r doing, but anytime I upgrade a drive I use Marcium Reflect to clone or image the drive. I have never used the data migration tool. Since u r going from a 120 to a 240 u can extend the drive after cloning. That will produce a bit-bit copy and everything should be good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.