I have an MSI K9A2 CF-F mainboard that its BIOS is so strange (AMI). I cannot flash the BIOS because every time after flashing it, it went to black screen after a reboot even the flash util said flashing was successful. I always have to take it to a repair shop to burn the BIOS using a chip burner. That's not making any sense because I can always successfully flash my other two mainboards without any problem.

So I have decided to find out what's wrong with it, and I use different flash utils to save some copies of current BIOS. The strange thing is, every time I restart the machine and backup the BIOS, I got a different copy! I have tried to boot the machine to DOS, windows xp and windows vista, use different flash utils to backup, and NONE of the backup copies is the same as the original. All the backup copies are different, too. Is there something wrong? How can I verify the backup copy is right or wrong?

Can anyone give me some tips? Thanks!


See if the repair shop can get a consistent readout of the BIOS image. Also consider there might be another problem, like memory (or the way the BIOS is configuring memory).

|improve this answer|||||
  • I'll take my mainboard to the repair shop next time I flash a new BIOS and try that. Regarding the memory, is there some memory setting can affect the backup result? I have tried to change memory hole mapping setting but seems it's not affecting this problem. I was thinking maybe it's because the BIOS was cached in memory but there was no BIOS caching setting for the mainboard in CMOS. – Miller Feb 5 '10 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.