6

I succesfully installed android-x86-6.0_20160129.iso in VirtualBox but the VM doesn't start.

This is my GRUB:

enter image description here

If I start the VM with the first option I get error Failed to find cpu0 device node. I found out that it's just a non-blocking warning and it's unrelated with the real blocking-issue being that "uvesa (v86d) is broken" (the issue was related to Android 4.4: is it still valid on 6.0?)

enter image description here

If I choose the Debug mode, I see some messages and a hint to type exit to boot, but still no success

enter image description here

enter image description here

Some background:

  • The VM was created from the Ubuntu 32-bit (x86) VirtualBox template
  • The VM has 1 core + 3096 MB RAM
  • Video memory: 32 MB
  • PAE/NX enabled
  • Hardware virtualization: both VTx and nested pagination enabled
  • Graphics acceleration: disabled (both 2D and 3D)
  • Storage: 64 GB attached to IDE virtual controller (was SATA before: makes no difference)

I've already tried all the "standard" VirtualBox procedure (PAE yes/no; SATA/IDE; no soundcard; no USB; graphics accel. yes/no).

I also tried run the Live CD in VESA mode: like this it starts, but I'd still prefer to run it from the HDD.

  • Have you tried using two cpu cores? – user573465 Mar 21 '16 at 15:32
  • @Robert : I have now: no difference – Dr. Gianluigi Zane Zanettini Mar 23 '16 at 22:28
  • tried this on DebianLinux-VirtualBox and I got to the colorful 'circles' screen but no further - it just sits there endlessly (1GB RAM+1x1stgen CPU core) – user289814 Apr 26 '16 at 3:07
3

This worked for me.

  1. At the Grub screen, press e.
  2. Press e again. Add vga=788 (need a leading space).
  3. Press b to boot.

To make this permanent, at the Grub screen, select the second choice. Then follow these steps.

  1. cd /mnt/grub
  2. vi menu.lst
  3. On the 7th line which starts with kernel, press a and then type vga=788 (need a leading space).
  4. Press Esc, then :wq to save the file and quit.
  5. Press the right Ctrl key, select Machine > Reset and then click "Reset".

The error will still appear, but now it will continue on.

0
  1. At the Grub boot screen press 'e'
  2. Edit the boot command and add:

    'acpi=off'
    
  3. Press B to continue booting into Android 6.0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.