6

My router cannot ping an IP-Camera attached to a switch. Therefore I cannot reach this IP-Camera from over the internet using port forwarding.

enter image description here

Other PCs can ping the IP-Camera within the network. The router cannot.

The IP-Camera is connected to the switch. The switch is connected to the router.

(I have another switch but disconnect it when doing any testing/changes)

I have tried connecting the IP-Camera directly to the router and it pings successfully.

ADSL Router DSL-2890AL - Manual

IP: 192.168.0.1 | 255.255.255.0  
DHCP: enabled, IP 100-200 (most of my devices are static) Relay is disabled.  

enter image description here

enter image description here

Switch TL-SG2210P - Manual

IP: 192.168.0.28 | 255.255.255.0  
Gateway: 192.168.0.1  
DHCP: not featured 

enter image description here

enter image description here

IP-Camera Network Config http://www.longse.com/Info/View_pro.asp?id=762

IP: 192.168.0.27  
Netmask: 255.255.255.0  
Default Gateway: 192.168.0.1  
DNS: 192.168.0.1  

Ping patterns from router to Devices

SUCCESS: IP-Camera[ip27] connected to router as ethernet + power
FAIL: IP-Camera[ip27] connected to switch to router as POE
FAIL: IP-Camera[ip27] connected to switch to router as ethernet + power supply

SUCCESS: Laptop[ip24] connected to switch to router
  • Questions... Can you post the IP configuration for 192.168.0.27? Any software firewall products running on it? Is the PC able to otherwise communicate with the router / connect to the internet? – BrianC Mar 23 '16 at 1:44
  • I see... thanks. So VLANs shouldn't be an issue but did you make any other configuration changes to the switch, or is it just configured to be a "dumb" switch? Is port isolation restricting any traffic between the IP camera port and the router? Do you see any warnings / errors in the switch's log table? – BrianC Mar 23 '16 at 2:23
  • @BrianC: port isolation is default. I have posted a screen shot. Any trial config changes are reversed immediately and is otherwise default. I am now going to restore defaults to switch before reassigning basic network config. Be back with result soon. – Valamas Mar 23 '16 at 2:26
  • @BrianC: I have reset to factory defaults and only applied correct system time and IP address 28 & gateway 01. Still no ping – Valamas Mar 23 '16 at 2:43
  • @BrianC: no errors in log of switch – Valamas Mar 23 '16 at 3:01
2
+50

Doh, ICMP of course!! I have the exact same setup as you and have been messing around for hours. Are far as I can tell the only thing I have done is to change the switch IP onto the same network as the router 192.168.0.nnn and enabled then disabled SNMP and suddenly everything works. I have also just updated the firmware to the latest version from the TP-link website but ping was working before I did that. In all honesty the only thing that appears to have made ping work is by enabling SNMP and now after disabling it - ping still works.

I can't explain it - and it makes no sense - but it worked!

  • SNMP was disabled by default. I enabled, rebooted, pinged, then disabled, rebooted, pinged. In all scenarios ping did not work from router to ip-camera. Also, firmware was the latest version already. – Valamas Mar 23 '16 at 20:53
1

If your PCs can ping this, you should be able to access the camera and it's web page.

Your diagram shows everything plugged into the switch. So regardless if you had a router or not (you're not even using a GW really in this scenario) you still have routing access to the camera.

Looking at this you have a managed switch. Since your PCs can ping this Camera but your router cannot, my guess is the port that the router is plugged into cannot reach the port that the camera is plugged into. Check your port settings for the router and see if there is a tagging issue or something setting wise different from the other ports. If you don't have a lot of important settings, also try resetting your switch (you should be able to backup a switch config as well) and see if an out of the box switch config has the same results.

Personally, I would start with switching the ports with a known good pingable port (Switch a PC port with the camera port and see if the results are the same or switch the router port and a PC port to see if the PC can still ping and if the router cannot etc.)

  • PC is not connected to the switch. Also have been switching ports and using cables in any change that were also know good pingers. I have lots of trusted cables. – Valamas Mar 26 '16 at 2:05
  • I'm assuming the end result you're wanting is to view the camera outside of your network via phone etc? I would be curious what the results would be from a reset switch/router. Your switch config looks relatively basic...have you tried to reset the router/switch and pinging again? Also, does your router have ports on it? I would definitely plug the camera into one of those (where your PC is plugged into since it's not in the switch) and see if the router can get to it from there. That will answer a lot of questions I think or help narrow down the issue. – Zachari Whitney Mar 29 '16 at 15:32
1

The problem was with TP-link and their failure to display a correct list of firmware as I needed a firmware update.

However, TP-link had the firmware linked on .com.au website and .com website. The .com.au was missing a page update listing two more versions when compared to the .com web page.

Other than the missing updates, the page design was the same.

TP-link support was good but their failure to update or have a single page for the english site cost me days in time and frustrating testing.

1

Just ran into a similar problem - SG2210 + 1043ND. Client connected directly to router could ping internet/lan, but the switch was unreachable, also connecting clients to the switch resulted in loss of connection to DHCP server (router).

Even setting the switch's admin IP to the same subnet didn't help. After installing the latest firmware everything looks goodk - however it wasn't easy to figure out that there was a newer firmware here:

Firmware than at the first site found by google search. I also noticed that there are different "latest" versions for other devices (for ex. EAP120) on different sites, though they are intended for the same device and same HW version. That should be revised by TP-Link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.