32

In Windows 10 (Pro, 1511 build 10586.104), default web browser keeps being reset to Internet Explorer at each reboot (settings > system > default). No matter which other browser is set there, as admin, after reboot default browser is Explorer again.

Is there a way to prevent that?

3
  • 1
    Pushing IE11 instead of pushing Edge? That's weird if one assumed its all evil Microsoft's fault
    – infixed
    Mar 15, 2016 at 11:01
  • 2
    I have the same problem. For me, even logging off and logging back on again resets it back to IE.
    – Sam
    Jul 28, 2016 at 4:09
  • I have the same issue with 1511 and 1607. I have a suspicion it may be related to synchronizing settings between machines but can't be sure until I turn that off for a while. Dec 14, 2016 at 18:18

6 Answers 6

4

It worked for me:

1.Right click on start > Task manager

2.Click on more details

3.Go to Details tab

4.Find explorer.exe > Right click > Click "End Process" (Do not close Task manager) 5.Go to file > Run new task > type explorer.exe and check create this task with administrative privileges. > OK

6.Go to start > Setting > Apps > Default Apps > Web Browser > Click on Microsoft edge > select your favorite browser.

7.Restart

6
  • 3
    Unfortunately this didn't work for me :(
    – Jalal
    Jan 10, 2019 at 11:22
  • Does not work. At reboot, again the default browser is reset to IE. The setting change takes, and is reflected as the default. But upon reboot, its right back to stupid outdated obsolete IE.
    – Minok
    Feb 25, 2019 at 18:57
  • This was working until beginning of 2019, hence the accepted answer. I'm now running Windows Enterprise 1803 build 17134.590 and it's still working. Mar 13, 2019 at 14:48
  • "check create this task with administrative privileges" there is no such option unfortunately in 2020 Nov 2, 2020 at 10:33
  • @BlueClouds yes, there is, but you need to launch the Task Manager with administrative privileges for the checkbox to be there. Nov 2, 2020 at 13:42
3

Turn off Internet Explorer.

Be an Administrator user or Accept administrator prompt for this to work.

Steps:

  1. Search "Turn Windows features on or off" {Control Panel > Programs > Programs and Features > Turn Windows features on or off (Visible on Left)}
  2. Disable "Internet Explorer.." from Tree
0
0

Search for defaultassociations.xml, delete it. You'll need admin rights on the machine. Then go to the normal 'set default apps' menu and make your selections. Reset and you should be all set!

1
  • No such file on the system drive (C:) for Win10.
    – Inversion
    Oct 25, 2019 at 20:13
-1

Click on (3) dots right corner. Go to "Settings". On far left, click on "Search Engines" then "Manage Search Engines", remove unwanted search engine. Choose your search engine on line above. McAfee seems to be my culprit.

-2

Follow these steps to change a default browser back to Firefox or Chrome

  • Click the menu button and choose Options.
  • In the General panel, click Make Default….
  • The Windows Settings app will open with the Choose default apps screen.
  • Scroll down and click the entry under Web browser. In this case, the icon will say either Microsoft Edge or Choose your default browser.
  • In the Choose an app screen, click chrome or Firefox to set it as the default browser.
  • Firefox or Chrome is now listed as your default browser. Close the window to save your changes.

Hope this answer helps

1
  • 5
    If I understood the question, this sounds like what the OP is doing, but the selection is being changed at reboot.
    – fixer1234
    Mar 9, 2018 at 7:52
-3

Try this:

  1. Right click at Start button
  2. Click Control Panel
  3. In the top right, click View by
  4. Click either large or small
  5. Click Default Programs
  6. Click Set your default programs
  7. On the left side, do you see your Cyberfox? If yes, click it
  8. On the right side, click "Set this program as default"
  9. Click OK when done

Not the answer you're looking for? Browse other questions tagged or ask your own question.