4

I have a single Windows 10 machine. It is not connected to a domain. Pretty stock. Daylight savings time changed this weekend, and my computer is not showing the correct time. I've rebooted it with no change in the issue. If I set "Adjust for daylight savings time automatically" then the time is wrong. If I turn this feature off, then the time is right. It seems like the opposite should be true. Can someone help me to get my OS to report the correct time throughout the year?

Screenshots to demo the problem to follow..

Time is wrong when "Adjust automatically" is set:

Time is wrong when "Adjust automatically" is set

Time is correctly when this is disabled: Time is correctly when this is disabled.

  • 2
    Why do you have "set time zone automatically" turned off? is your Network Time Protocol (NTP) source correct? – Ramhound Mar 15 '16 at 18:44
  • NTP was set to Microsoft default. That server was failing, it turns out. I switched to pool.ntp.org and time sync'ed perfectly! – stevemidgley Mar 17 '16 at 15:10
  • See the answer in this one: superuser.com/questions/1214735/… where I mention that the primary national time server is time.nist.gov – SDsolar Jun 16 '17 at 9:37
9

In general, "Adjust for daylight saving time automatically" should always be On. Turning it off is for a few legacy edge cases and a couple of places in the world that don't currently have an appropriate entry in the list of time zones.

Most likely, the system clock isn't set to the correct time. Perhaps there's a problem getting the correct time from the Internet, which is enabled or disabled from the first "Set time automatically" option.

I recommend:

  1. Check that your Internet Time Server settings are correct. Try a different time server if necessary.

  2. Turn on all options, being sure to turn on "Adjust for daylight saving time automatically" before turning on "Set time zone automatically".

| improve this answer | |
  • 2
    It never occurred to me that the time server might be failing! But that is the case. I switched to pool.ntp.org and the time is sync'ed correctly now. I re-enabled auto-daylight savings and my time is correct. Thanks! – stevemidgley Mar 17 '16 at 15:09
  • In my case none of the servers in the drop down worked. Also tried pool.ntp.org, all failed with same error : timeout period expired... Stil dont know how to solve this problem. I am in India and we don't have DST but still Windows shows wrong time, this is very frustrating – nanosoft Apr 30 '17 at 11:37
2

This has just happened to me this week on a Windows 10 machine, as we entered Daylight Saving Time in some regions here in Brazil, even with the "Adjust for daylight saving time automatically" enabled. Windows did recognize DST, but the clock kept on going to the wrong time zone: UTC instead of UTC-2 (DST from Brasília's UTC-3).

It has been solved by changing the NTP server to pool.ntp.org, as @MattJohnson and @stevemidgley indicated above. At first, it seemed "time.windows.com" server might not be up-to-date in its time zones settings, but the time configuration remained OK after returning the server to "time.windows.com".

What I've also noticed is that time zone settings frequently stalls on Windows 10, requiring using Task Manager to kill its processes.

| improve this answer | |
  • In my case none of the servers in the drop down worked. Also tried pool.ntp.org, all failed with same error : timeout period expired – nanosoft Apr 30 '17 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.