3

I get the following error inside /var/log/syslog on Ubuntu 14.04 when I try to pair with my Bluetooth speakers (although it used to work well few days ago:

Mar 15 19:58:39 hakim bluetoothd[1395]: Permission denied (13)

Do you know what's causing this error? and whether I should change my Bluetooth manager (note that my system is up-to-date)?

6

I solved this issue, simply by removing the bluetooth device from the bluetooth icon on the menu bar, re-scanning, and adding it.

1

this is an open bug :
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/437649
although some solved their issues.

2
  • Actually, I solved it by removing the bluetooth device and setting a new device. – Hakim Mar 25 '16 at 13:05
  • 1
    @HakimBenoudjit You should post your resolution as an answer. – root Mar 28 '16 at 14:54
1

In my case, the cause of the error was that the audio device I wanted to connect to was already paired to another device. Disconnecting it and rebooting the device solved the issue.

0

It could be that your user doesn't belongs to bluetooth group, you can review your grous typing id command in a terminal or add your user with:

sudo usermod -a -G bluetooth $USER
1
  • I tried this and it did not change the error message described in the original question. I ended up having to remove the device and re-pair it. – gene_wood Jun 29 '20 at 17:01
0

This Wiki helped me out a lot.

Os = Ubuntu Mate (Release 20.04 LTS (Focal Fossa) 64-bit)

 Release 20.04 LTS (Focal Fossa) 64-bit

 MATE 1.24.0

 bluetoothctl version = 5.53

Procedures I followed on the Terminal:

$ bluetoothctl agent on

$ sudo bluetoothctl --monitor

# scan on

# pair xx:xx:xx:xx:xx:xx ...(Here input your device's address from the scan results) - You will be presented with a pin request ... usually 1234 or 0000(For speakers and/or headsets) should work. If you are pairing with a phone you can use any four digit pin since you are gonna input the same on your device...

`[agent] Enter PIN code:` 0000

# connect xx:xx:xx:xx:xx:xx (again your device's address)

# trust xx:xx:xx:xx:xx:xx ... (for future auto-reconnects)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.