3

I installed Kali alongside my Windows10. I decided to uninstall Kali, so deleted the partitions and used EasyBCD to restore back to Windows MBR. Upon boot Grub rescue still loads. So I ran a live Ubuntu and ran boot-repair which also didn't remove Grub rescue. Im wondering if I have any other options to try to remove Grub rescue, or a link to a guide would be handy. Bottom of my post has Boot-repair report

Windows boots as EUFI, I can toggle this to secure and it boots straight to Windows. But Id rather know how to have a clean MBR with no Grub rescue

Ubuntu Pastebin http://paste.ubuntu.com/15399387/ (My Windows 10 is on SSD and has 7 partitions)

Paste from boot-repair at Wed, 16 Mar 2016 02:50:36 +0000 Download as text

Boot Info Script e7fc706 + Boot-Repair extra info [Boot-Info 9Feb2015]

============================= Boot Info Summary: ===============================

=> Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 197275648 of the same hard drive for core.img. core.img is at this location and looks for (,gpt10)/boot/grub. => No known boot loader is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

File system:       vfat
Boot sector type:  Windows 8/2012: FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        /EFI/Boot/bootx64.efi /EFI/Microsoft/Boot/bootmgfw.efi 
                   /EFI/Microsoft/Boot/bootmgr.efi 
                   /EFI/Microsoft/Boot/memtest.efi

sda2: __________________________________________________________________________

File system:       vfat
Boot sector type:  Windows 8/2012: FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sda3: __________________________________________________________________________

File system:       
Boot sector type:  -
Boot sector info: 
Mounting failed:   mount: unknown filesystem type ''

sda4: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sda5: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        /bootmgr /Windows/System32/winload.exe

sda6: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sda7: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sda8: __________________________________________________________________________

File system:       
Boot sector type:  -
Boot sector info: 
Mounting failed:   mount: unknown filesystem type ''

mount: unknown filesystem type ''

sdb1: __________________________________________________________________________

File system:       iso9660
Boot sector type:  Unknown
Boot sector info: 
Mounting failed:   mount: unknown filesystem type ''

mount: unknown filesystem type '' mount: /dev/sdb1 already mounted or /mnt/BootInfo/sdb1 busy

sdb2: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT16
Boot sector info:  According to the info in the boot sector, sdb2 starts 
                   at sector 0. But according to the info from fdisk, 
                   sdb2 starts at sector 26268. According to the info in 
                   the boot sector, sdb2 has 0 sectors.
Mounting failed:   mount: unknown filesystem type ''

mount: unknown filesystem type '' mount: /dev/sdb1 already mounted or /mnt/BootInfo/sdb1 busy mount: /dev/sdb2 already mounted or /mnt/BootInfo/sdb2 busy

ubuntu@ubuntu:~$ sudo efibootmgr -v

BootCurrent: 0014
Timeout: 0 seconds
BootOrder: 0000,0010,0011,0012,0013,0014,0015,0016,0017,0018,0019,001A,001B
Boot0000* Windows Boot Manager  HD(1,800,fa000,b953817c-7fe7-4055-900b-257313796755)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...r................
Boot0010  Setup 
Boot0011  Boot Menu 
Boot0012* Removable Drive   030a2400d23878bc820f604d8316c068ee79d25b20699b27e1a34f488e97534d40523c1d
Boot0013* Hard Drive    030a2400d23878bc820f604d8316c068ee79d25bf5b01cc8ce8e9841b3a8fb94b6dfefee
Boot0014* USB Storage Device    030a2400d23878bc820f604d8316c068ee79d25b6895f49a99882e4bb0da03ec784d2828
Boot0015* CD/DVD/CD-RW Drive    030a2400d23878bc820f604d8316c068ee79d25b3750dce1249e1748876bee5d3f25ebfb
Boot0016* Network   030a2400d23878bc820f604d8316c068ee79d25b6567de8ee595634d842b325e6a43510b
Boot0017* Onboard NIC   030a2400d23878bc820f604d8316c068ee79d25b1b7f7356e3475744a9a6ed8e91832083
Boot0018* Onboard NIC   030a2400d23878bc820f604d8316c068ee79d25bb4a054dda1fa7043abf832c5a88367a6
Boot0019  Diagnostics   
Boot001A  Peripheral Device setting (OPROM setting) 
Boot001B  Change boot mode setting  
ubuntu@ubuntu:~$ 


ubuntu@ubuntu:~$ sudo hexdump -n 512 -C /dev/sda

00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*

000001c0  02 00 ee ff ff ff 01 00  00 00 af c2 e7 0e 00 00  |................|

000001d0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*  

000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
00000200
0

Apparently your Windows is a UEFI installation but you installed Kali/grub for the CSM ("legacy boot").

Try to wipe the protective MBR and let gdisk write a new one for you:

dd if=/dev/zero of=/dev/sda count=1
gdisk /dev/sda
w

Make sure you do not miss count=1 because if you do, dd will be wiping your WHOLE drive.

  • Thanks Tom, Grub has no been removed, when I before sudo gdisk /dev/sda said <blink>MBR: not present BSD: not present APM: not present GPT: present</blink> and now when I enter gdisk /dev/sda it says MBR: Protective BSD: not present APM: not present GPT: present – Ryan Mar 16 '16 at 20:47
  • Can you attach the output of efibootmgr on your post then? – Tom Yan Mar 16 '16 at 20:55
  • ubuntu@ubuntu:~$ sudo efibootmgr BootCurrent: 0014 Timeout: 0 seconds BootOrder: 0000,0010,0011,0012,0013,0014,0015,0016,0017,0018,0019,001A,001B Boot0000* Windows Boot Manager Boot0010 Setup Boot0011 Boot Menu Boot0012* Removable Drive Boot0013* Hard Drive Boot0014* USB Storage Device Boot0015* CD/DVD/CD-RW Drive Boot0016* Network Boot0017* Onboard NIC Boot0018* Onboard NIC Boot0019 Diagnostics Boot001A Peripheral Device setting (OPROM setting) Boot001B Change boot mode setting ubuntu@ubuntu:~$ – Ryan Mar 16 '16 at 20:58
  • You better put the output on your original post by editing it. Also my bad, efibootmgr -v instead of just efibootmgr. – Tom Yan Mar 16 '16 at 21:06
  • Can you add hexdump -n 512 -C /dev/sda to your post as well? Maybe also compare the checksums (e.g. md5sum) of /EFI/Microsoft/Boot/bootmgfw.efi and /EFI/Boot/bootx64.efi on the EFI system partition (sda1). Do you currently have Secure Boot enabled? Coz according to efibootmgr, Windows Boot Manager is the first active boot entry, so you should not see grub rescue. – Tom Yan Mar 16 '16 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.