2

I've got an ASUS RT-AC68U which has both a 2.4GHz and 5GHz network. My Win10 laptop can connect to the 5GHz network and everything works perfectly.

When I try to connect to the 2.4GHz network, it appears to connect but doesn't actually work. It pulls an IP but I can't ping the router or connect to anything on the network/internet.

I thought the 2.4GHz radio for my router was bad because I get the same result with another windows computer. However, my android phone can connect to the 2.4GHz network and surf.

I've tried uninstalling/reinstalling the network adapter but that didn't help. What are some other steps I can try?

Edit:

My windows 10 computer is a Lenovo Z50-70 whose specs can be found here with the exception that I upgraded to windows 10 and now have version 1511 OS build 10586.164

My other computer is an old Sony Vaio with Windows 8.1. It has a Qualcomm Atheros AR9285 Wifi adapter. I also tried it with a RTL8188CU USB adapter. Both adapters had same result. If I use the wired ethernet connection then that works. Neither of the devices are capable of 5GHz so I can't test this computer's access to that side of the router.

I can give more details if that would be helpful, I just don't know what other details may be helpful.

In summary, I have a wifi router with both 2.4 and 5GHz broadcasts.

My lenovo (win10) laptop can connect fine to 5GHz.

Neither my lenovo (win10) nor my vaio (win8) can connect successfully through the 2.4GHz broadcast.

However, my Android is capable of connecting through both the 2.4 and 5GHz.

Edit 2

I hooked up an old router and each computer was able to connect to it at 2.4GHz so now I'm left wondering what is so special about my Android phone that is it able to connect when other devices can't.

Edit 3

There is no MAC filtering on the router.

  • to whomever downvoted, why downvote? – Dean MacGregor Mar 16 '16 at 22:42
  • You told us nothing about the Windows machine. – Ramhound Mar 16 '16 at 22:56
  • Plus this question is basically this one – Ramhound Mar 16 '16 at 22:56
  • @Ramhound I added some info. Hopefully it is relevant. If there's other details that I neglected to add it was because I don't know why is helpful to know and what is just noise. – Dean MacGregor Mar 16 '16 at 23:33
  • Do you have MAC Address filtering enabled? – Ramhound Mar 17 '16 at 1:43
3

I also have the same router (Asus RT-AC68U). I had applied the latest firmware update (as of today is ver: 3.0.0.4.380.1842). But then my 2.4Ghz wireless devices would not work properly. I also thought it was a driver and/or Windows 10 issue on those laptops...(My 5Ghz devices were working fine)

I read other posts out there with people having similar issues. It seems the quick fix is to downgrade the firmware to version: 3.0.0.4.378.9313 ...which I did and now everything is working again on the 2.4Ghz. Obviously Asus latest firmware update broke something in the 2.4Ghz.

Link to firware update: http://www.asus.com/ca-en/Networking/RTAC68U/HelpDesk_Download/

Hope this can help someone else! Thanks.

  • 1
    I also have problems with wifi, even using asus merlin, 2.4 will be available with good signal but won't connect, no error just sits there "trying to connect" constantly. android connects fine. – rolls Jan 19 '17 at 4:53
1

There is a problem with the latest firmware. See this link https://vip.asus.com/forum/view.aspx?id=20160228031529455&board_id=11&model=RT-AC68U&page=1&SLanguage=en-us

  • 2
    Link only answers are frowned upon as they can become stale and invalid. To prevent stale links, you should summarize the answer from your link, and in this case be specific with version numbers. – acejavelin Mar 19 '16 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.