1

VirtualBox won't open. Here's what the error says:

Failed to create the VirtualBoxClient COM object.
The application will now terminate.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)

Screenshot:

It all started when I tried to install "Xamarin Android Player" and it installed a separate version of VirtualBox (I was originally on version 5.0.12, it tried installing version 5.0.4), so I tried opening it and it failed. I tried opening VirtualBox and I got that error, and it kept giving me that error through every version I installed (2.2 to 5.0.15) and I'm completely stumped.

My specs:

  • Computer model: Asus TransformerBook T100
  • CPU: 1.88 GHz quad-core Intel Atom CPU
  • RAM: 2 GB of RAM (I don't know what type)
  • Storage: 32 GB SSD with 3 GB remaining before install (424 MB after)
  • Operating system: Windows 8.1 with Bing

What can I do?

1
  • REGDB_E_CLASSNOTREG ultimately means "Class not registered."
    – bwDraco
    Mar 19, 2016 at 0:21

3 Answers 3

1

You will have to uninstall that Xamarin player AND Virtualbox completely. Then remove all traces of both that may have been left behind (Revo Uninstaller is a good tool for that).
If you have a system-restore point dating from before you attempted to install Xamarin it may be less hassle to go back to that.
Reboot and then FIRST install Xamarin, then VirtualBox.
Oldest version FIRST.

It is possible that that combination doesn't work either. If that is the case you will have to again completely uninstall both and then decide which one you really need and only install that.

Please note: Because you have been trying multiple versions of VirtualBox without cleanly uninstalling any of them it is possible your Windows installation is already damaged to the point it is no longer possible to get back into a clean state. If that is the case you hopefully have a restore point dating from before the time problems started. If not a re-install will be needed...

2
  • what if my windows installation is an OEM(Hence the "with bing" part) or the recovery media is broken (which doesn't allow a windows reinstall)
    – MrThrall
    Mar 19, 2016 at 17:15
  • Then you are (censored). Finding the "with bing" iso from a safe source is damn hard. I gave up and bought a legal win10 after trying to find win8 with bing for most of a day. :(
    – Hennes
    Dec 12, 2016 at 13:31
1

I actually fixed it... all i had to do was delete the ".virtualbox" folder in "C:/Users/"User"/.Virtualbox:(replace "User with your account's name"

thanks for the help guys. I really appreciate you guys giving me advice.

1

I havve solved the error:

Failed to create the VirtualBoxClient COM object. The application will now terminate.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)

  1. G to your USER folder ie Document&settings or Your Username folder

  2. You will see the .virtualbox folder

  3. Click on that folder and remove the virtualbox.xml file and the virtualbox.xml-prev file

  4. Again run vbox, it will automatically create the above file and it will run perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .