I'm on a private network with a lot of restrictions and monitorings. Every HTTPS connection results in SSL certification errors (maybe those people use "man-in-the-middle" approach to decrypt the HTTPS traffic in the network?)

So far I have tried the solutions from these questions.

But in my case, an exception still has to be added every time I visit a secured site. Also for some sites, resources (such as images, stylesheet, scripts) from different domains won't load and the sites become broken and unreadable.

www.google.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.


For Chrome, there is an unsupported command line switch --ignore-certificate-errors but it makes Chrome ignore all SSL certification errors. Is there any thing that would do the same in Firefox? (I'm using the latest version of Firefox on Windows 7)


1 Answer 1


Firefox has no such setting.

That's a terribly terse answer, but I'm afraid it's all there is. Firefox usually errs on the side of not letting you view a site at all in case of some problems rather than letting you override it even if you want to.

That said, if you're getting cert warnings for everything on a private network, it's almost certain that the local IT group is running an SSL interception proxy. You're not going to get to the internet without accepting their certificate, so here's how you do that:

  • Open up the certificate properties for one of the pages you get an error on (after adding the exception in Firefox) by clicking the lock in the address bar, the right arrow, and then "more information".

  • In the Security tab, click on View Certificate, and then the Details tab on the new window.

  • Under Certificate Hierarchy, examine the name of the topmost certificate. It's probably going to be from a security vendor of some kind like Symantec or Barracuda.

  • Click on it, and then go to Export at the bottom.

  • Save the file somewhere accessible

  • Close the security and certificate windows, and open your Firefox settings (top right hamburger menu, Options)

  • Click Advanced on the bottom left, and then click View Certificates

  • Click the Authorities tab, and then Import

  • Locate the file you just saved

  • Accept the warning.

It is very important you don't get into a habit of doing this procedure, and only to do it when you know with COMPLETE certainty that the certificate is legitimate. I cannot emphasize this enough - call the IT people and have them verify the name on the certificate if you're even slightly unsure, since now you've just told Firefox to accept any and all certificates that the CA you just imported signed. You will receive no more warnings of that sort for this cert. If you import a malicious certificate, you've just shot yourself in the foot.

  • 1
    MikeyT.K. answer is correct - what you are doing - simply put - is abdicating control to your connectivity to whatever is M-I-T-M attacking you. Another solution might be to use a VPN with a provider which allows you to use OpenVPN with the http-proxy directive to tunnel untampered Internet through the restricted firewall.
    – davidgo
    Mar 19, 2016 at 3:33
  • 4
    @Mikey T.K.: I tried to export the certificate from Reddit (as an example) like you told me to. But when I imported it, Firefox gave this error message This is not a certificate authority certificate, so it can't be imported into the certificate authority list. Here is the screenshot of the certificate export: Image
    – Teiv
    Mar 19, 2016 at 4:45
  • 2
    @davidgo: In my workplace, such things like VPN, SSH, SOCKS, HTTP proxy or even web proxy will result in an instant ban from the network and only an official request from my manager may help me to access the network again.
    – Teiv
    Mar 19, 2016 at 4:46
  • 2
    Don't verify just the name; verify the certificate fingerprint. That's a lot harder to fake.
    – user
    Mar 22, 2017 at 14:04
  • 2
    Still, a --ignore-certificate-errors option would be helpful. Corporate environment here, we use Firefox only to access hundreds of ILO-consoles, all of them are vendor-configured with an invalid certificate. So for every one of them we get a certificate warning :-\ Not sure if this can be solved in #435013, maybe a new report is in order...
    – ckujau
    Jun 1, 2018 at 6:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .