1

I recently reinstalled Windows 10 on my Dell XPS Laptop. On my older system, I had the admin auto logon feature turned on via the registry settings. This setting required a defaultPassword String value in the winlogon registry node. Since my previous system only had a local account with a password instead of PIN, I'm not having trouble to setup auto login on my new system on which I've added a PIN login for my Microsoft account.

I don't need the PIN disabled, cause I don't intend to allow access to my system on wakeup/lock-screen/or restart.

I have added a lockscreen.bat:: (rundll32.exe user32.dll, LockWorkStation) to my startup folder on Windows 10. This batch file locks my computer after it's restarted and logged in.

I'm trying to disable login on system start, and then lock it again via the batch script to allow loading of programs etc, to avoid delayed startup caused by windows start stuck at login.

On my previous Windows 10 machine, this was done easily, although now it's difficult due to the PIN. Error is that it says that the username password don't match.

  • You can't; You can only auto-login with a password, you need a password, to have a pin so that should be doable – Ramhound Mar 19 '16 at 14:03
  • Sound like your auto logging into the wrong account currently – Ramhound Mar 19 '16 at 14:04
  • I have the password to my Outlook account, although during Windows 10 installation, I had set up a PIN code to login instead of logging in to my account with my account password every time. I'm not signing in to the wrong account.. It's just I thought there would be a registry string DefaultPIN instead of normal DefaultPassword (in Winlogon) .. – mk117 Mar 19 '16 at 14:07
  • 1
    You "had" to set it up? A pin is optional...a password is required if you want to use a pin – Ramhound Mar 19 '16 at 16:33
  • I knew the PIN was optional, although I preferred PIN over @outlook.com password to prevent logging in to my outlook account on each system restart! Also, for autologin, keeping the outlook password in registry as string is not secured! – mk117 Mar 19 '16 at 19:41
3

It sounds like you're avoiding disabling the PIN, but if you are willing to disable it you can get auto login working this way:

1. Disable your PIN

  1. In the Start menu click the Settings gear/cog.
  2. Click the Accounts section.
  3. On the left choose Sign-in options.
  4. Under the PIN heading click Remove.

2. Enable Auto Login

  1. Open a Run dialog (press R while holding the Windows key) and type netplwiz and press Enter or click OK.
  2. In the dialog that opens uncheck "Users must enter a user name and password to use this computer." and click OK or Apply.
  3. It'll ask you to provide account details to auto login with -- provide that and click OK. Make sure you enter this correctly! If you don't it will still accept it and you just won't auto login later.

After that on the next restart you'll auto login!

0
  1. Enable Autologin (see post above)
  2. create a reg file (DefaultLogIn.reg - replace "YOUR_USER_ID_HERE" with your id from the reg entry)

    Windows Registry Editor Version 5.00    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserTile]
    "YOUR_USER_ID_HERE"="{D6886603-9D2F-4EB2-B667-1971041FA96B}"
    
  3. create a batch file (LockScreenAndChangeDefaultLogInMethod.cmd - change path)

    @echo off
    C:\Windows\regedit.exe /s "D:\Documents\DefaultLogIn.reg"
    %windir%\System32\rundll32.exe user32.dll,LockWorkStation
    exit
    
  4. create a shortcut to the batch file in the autostart folder of the user (shel:startup)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.