7

When I'm playing CoD Black Ops 3, the game crashes and I get an error that says:

Application "blackops3.exe" has been blocked from accessing graphics hardware

It crashes always when I play it, just after a varying amount of time (depending on the settings and the game mode).

The game freezes and when I open task manager, the game goes black and I can see the error message, but I can still hear the game audio.

I tried to:

  • update the graphics drivers

  • completely lower the settings (1024x768 resolution, 50% resolution scale, FPS limit 30, everything to low or off if possible)

  • uninstall drivers with DDU and (manually) delete all GPU driver related registry entries

  • set TdrDelay to 8 (setting it to higher values just makes the game frozen for longer before getting a black screen); that fixed the "Display driver stopped responding and has recovered" problem I had before this

  • set TdrLevel to 0 (turn off TDR completely), it just completely freezes everything and I have to kill the computer with the power button

  • uninstall and install the GPU through Device Manager

  • reinstall the game

  • reinstall Windows

  • go back to Windows 7

  • increase paging file size

  • BO3 is allowed through the firewall, as well as Steam

  • running in compatibility mode for Windows 7/8

  • running as admin

  • setting process priority to high (it just gets reverted to normal)

But none of the above fixed the issue.
The game worked perfectly for the first three or four weeks when I bought it and then it started giving me the "Display driver stopped responding and has recovered" error. After fixing that, I started getting this error.

I am confused and I tried so many things because the game worked before, I get 50 - 60 FPS easily and most of all, the previous CoD (Advanced Warfare) which has almost identical system requirements doesn't crash at all (even at relatively high settings). With that taken into consideration it seems that my computer is able to run BO3 but it just doesn't feel like doing it.

Why is this happening, and if you know, how do I fix this?

By the way, here is a screenshot of a private match with bots and one from before where guns look like clay (the textures don't load properly), although this doesn't happen anymore (see update 4). I know the second screenshot is bad, but that's the only one I have which shows this issue.

EDIT:

I see no one has any idea how to fix this. But as @user3064419 said, what is blocking the application in the first place? Is there any documentation about this error?

Any help would be appreciated.

UPDATE:

So I thought that this may be caused by corrupt files.

I ran sfc /scannow in cmd and it came up with this:

Windows Resource Protection found corrupt files but was unable to fix some of them. 
Details are included in the CBS.log windir\Logs\CBS\CBS.log. 
For example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
supported in offline servicing scenarios.

The log says that opencl.dll is corrupt. Does this have anything to do with my problem?

UPDATE 2:

So I used DISM.exe to fix the corrupt file and sfc /scannow now reports no errors. But it doesn't seem to make any difference.

UPDATE 3

I think that if I modify the config.ini file, I could achieve something. You can see the file contents here. I assume that the most important values are VideoMemory, CorpseCount, MeshQuality, TextureQuality, TextureQualityFX, TextureQualityProbes and TextureQualityBakedSunShadows. I have set all of these to minimum. Also, I saw a value at the end of the file called StreamMinResident. Its description is Reduces memory reservations on systems with low GPU memory. and it can be 0 or 1 (off\on, boolean value). I set it to 1, but it doesn't seem to do much.

UPDATE 4

Something weird has been happening recently. Textures and camos load properly even in public matches (i.e. guns don't look like clay anymore, see above) and I have been able to complete a few campaign missions.

UPDATE 5:

Now I have played the Battlefield 1 open beta and that runs beautifully. By that I mean the resolution is set to 1280x1024, resolution scale to minimum (or just a little bit), all settings to low (except AA which is set to minimum, not off), the game runs at about 45 - 60 FPS and most importantly, doesn't crash at all.

Now I think the key thing here is the resolution scale. The same setting exists in Black Ops 3 where it can be reduced to minimum 50%, however in Battlefield 1, it can be reduced even further. The strange thing is that, in Black Ops 3 I set it to 50% and the game crashes, but in Battlefield 1 when I set it to 50%, it still doesn't crash, only the framerate becomes unbearable.

UPDATE 6:

OK, I'll have to stop numbering the updates. Recently I broke Windows on my computer. When booting, it would refuse to do it and say "Your PC has ran into a problem and has to restart". Then it would restart and do this again in an infinite loop.

I removed and installed Windows 10 again with Bootcamp properly and for the first two days, the game worked perfectly and now it started showing the Display driver has stopped responding and has recovered error. What?! I know I can set TdrDelay to 8 or whatever, but then I'll start getting the error in the title. I haven't done anything with driver updates and things like that.

I've thought of something. Could this be caused by a non-activated copy of Windows?

System:

  • Windows 10 x64

  • Intel Core i5 4th gen @ 2.6 GHz (turbo boost up to 3.3 GHz)

  • Intel Iris 5100 graphics

  • Bootcamped Macbook Pro mid-2014

Note: I am crazy enough to play Black Ops 3 on a Mac (you don't have to tell me)

  • Nvidia has a driver setting to cache shaders for future use (to speed up shader loading). I think they are stored in the user profile area or (?), but the point is they are external to drivers and game files. Have you tried disabling this feature to rule out a bad cache? – Yorik Jun 7 '16 at 19:29
  • @Yorik I don't have an Nvidia GPU. Is there a similar option for Intel's GPUs? – syntax_error Jun 8 '16 at 5:16
  • Little late, but w/e: OpenCL.dll (not OpenGL) is always corrupt for some reason. This is not an error. – Daniel B Jul 5 '16 at 16:19
  • Finally, someone! Thanks, that's another thing ruled out! – syntax_error Jul 5 '16 at 19:07
2

I had the same problem (Application "portal2.exe" has been blocked from accessing graphics hardware), only with Portal 2 rather than Black Ops 3, and after finding no help online, I started messing with settings, and found a fix (at least on my computer).

Open Intel HD Graphics Control Panel -> 3D -> Conservative Morphological Anti-Aliasing -> Turn Off

My computer has Intel HD 4400 Graphics, Win 10 x64, and no other graphics card.

EDIT: Note: this does reduce performance is some games!

1

I have a fix for those who are running a CLONED TV or monitor. That is your problem. Nvidia helped me with this after a dozen other suggestions this finally worked. I unplugged the HDMI serving my secondary cloned HDTV and just ran the video card on my primary desktop monitor (which is using Display Port cable). Voila !!! No more error message!!! Nvidia suggests if you want to clone a secondary monitor or TV to try using the EXTEND function instead, which I will try when I get the time. But in the mean time just unplugging my cloned TV has eliminated this error message and now I can play my 3d games again. Hope this helps.........let me know!!!

0

You are trying to run the game using Intel Iris 5100 graphics. The minimum requirements specify NVIDIA GeForce GTX 470 w/1GB or ATI Radeon HD 6970 w/1GB. Your system does not meet the minimum requirements, and I believe the game itself is spitting back this error message as an indication.

  • It's quite possible someone else will have a better answer. Mine was somewhat of a speculation given the stated minimum requirements. Hopefully someone else will come along with a better answer! – ChrisInEdmonton Apr 18 '16 at 17:40
-1

I guess we have the same issue. Funny thing is that this only happens with COD MWF3 in my case. If I play BO2 no problem. Any other game: no problem. I have an ATI RADEON HD 5770. The problem seems to begin when latest update intalled AMD GAming Evolved an the app auto "optimized" all my library of games. The last thing I did was to erase the profile created for MWF3 inside that app and this afternoon I will try to see if that helps.

I will try again to use Display Driver Uninstaller to clean all the AMD drivers and I will try to install only the graphics drivers without all the other stuff (manual installation)

I have searched in many forums but no one seems to ask the right questions: WHY IS THE APPLICATION being blocked in the first place? and most important: WHAT IS BLOCKING the application? If we can answer that maybe the problem would be easy to solve. Anyway, lets hope we find an answer together. I feel your pain bro!

EDIT1: I couldn't test the fix attempt before because I was at work. I have successful uninstalled all drivers with DDU application which can be found here. You just need to uninstall and chose to reboot in safe mode, then continue with uninstalling of ALL drivers. After that, reboot in normal mode and install the latest drivers for your Graphics Card but be shure to untick AMD Evolved, just install Display Drivers and HDMI sound drivers and control center. AMD Evolded is creating profiles for games, which was my case. Reboot and at Radeon Settings be shure that your game is not listed the gaming menu. If it is, eliminate it from there. I also turned off my anti virus just in case. I'm running MWF3 in compatibilty mode and as admin. The game is running smoothier than before, to much smoothier. When the problem started, game was supper sloppy and suttering, now it is not crashing and is being very very smooth as it should be. My specs: Windows 10 Pro, AMD BLack Edition 3.4Ghz, HD 5770 and 8gb RAM. I really hope this may help you. Good day

  • First of all: I'm providing emotional support because this issue is very annoying. Second of all: I'm confirming that there are other alternatives (such as DDU app) which the author didn't mentioned so maybe he can try that and works for him. Third of all, the questions I made at the end are completely valid and lead towards a better answer by some expert. Fourth of all: your answer has even less valuable info, so why did you post it? – user3064419 Jul 5 '16 at 22:15
  • Nope, unfortunately it doesn't work. Maybe I should do something about the Intel Graphics Control panel? Thanks anyway. – syntax_error Jul 6 '16 at 10:45
  • If you can try to just install drivers without control panel to see if the raw mode helps, then yes, I guess it worth trying. I remember that both things happened before this error begun: Malwarebytes suddenly started to block MWf3.exe file IP and AMD Evolved app made a "special profile" for the game. That is why I tried both fixes and now I have no problem at all. Can you confirm you don't have any changes to Bo3 through the Cp? – user3064419 Jul 11 '16 at 16:53
  • I'll try to install the driver manually. And yes, I can confirm that I haven't made any changes in the Intel CP until I tried to fix the problem. – syntax_error Jul 11 '16 at 19:13
  • Installing the drivers by downloading the zip (and unzipping) and installing them with Device Manager still installs the Intel CP. Is it possible to manually copy-paste some of the files to the Windows folder (and/or its subfolders, wherever the drivers are located)? – syntax_error Jul 12 '16 at 17:33

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.