1

I have a D-Link DSL-321B modem and an Asus RN-N12E_B1 router.

The modem is connected directly with the internet. The router is the only device directly connected to the modem. My computer is connected with the router and gets its IP address via DHCP. I want to be able to access the Apache Web server (port 80) running on my computer from the internet. The server can be reached from within the LAN.

Here a little sketch to illustrate the topology:

enter image description here

Both devices have the option to port forward. Which device do I have to port forward how (and why)? I already tried all possible combinations but it doesn't work.

IP addresses to make explanations easier:

  • Modem global 84.141.XXX.XXX
  • Modem local 192.168.1.1
  • Router local 192.168.2.1
  • My computer local 192.168.2.216

Edit:

  • Enabling DMZ in the modem doesn't help either (pointing to the router).
  • DHCP is disabled in the modem. The port is forwarded on the router.
  • If the Modem is doing dhcp, Disable dhcp in the router, then do port forwarding in the modem. – Moab Mar 21 '16 at 0:33
  • did it. but still does not work. :( – Willi Mentzel Mar 21 '16 at 0:46
  • We need some more information to narrow down the problem. Are you able to access your webserver from the local network? – Hefewe1zen Mar 21 '16 at 1:28
  • @Moab How can the modem DHCP the devices behind the modem? the only device connected with the modem is the router. all other devices are connected with the router. – Willi Mentzel Mar 21 '16 at 14:41
1

First, check to make sure you can access the webserver from your local network. Once confirmed...

At first blush it looks like you're double NAT'd. Basically your modem and router are trying to do the same thing. If this is truly your problem, and you don't want to change any network configuration, then you'll have to forward ports twice. From your Modem to your Router, then Router to the webserver.

Your other options are to ask your cable company to put the modem into bridge mode. That way your router is assigned the public IP and you'll do all your firewall config there.

Or you can turn your router into a glorified hub by disabling routing functions, dhcp, etc. Your port fwding would be done on the modem.

Finally, your method of putting the router IP in the DMZ should work too...

  • port forwarding on both like you described doesn't work. the webserver can be reached within the LAN (put that in the question now). bridge mode is out of question, because i need pppoe which is only supported by my modem. But the router needs DHCP to split the conneciton to all clients? The only device which is connected with the modem (only one can be) is the router. or is the modem able to dhcp all the devices over the router (can it assign addresses to devices not directly connected to it)? – Willi Mentzel Mar 21 '16 at 11:24
  • i also added a highly sophisticated sketch to illustrate my topology :D – Willi Mentzel Mar 21 '16 at 11:33
  • I'm not too familiar with your specific router, but a quick search reveals it has PPPOE, so you should be able to bridge the modem. Otherwise you can disable DHCP on the router, and DON'T use the WAN port on the router to connect to the modem. What you want is to use the 4 ports as a switch; the modem should be able to give out IPs to everything this way. See the 'layer two trick' on this page, which has a nice pic graemenoble.id.au/post/48695277030/… – Hefewe1zen Mar 21 '16 at 15:16
  • where did you find that? as far as I know it does not have PPPoE. I had to buy a modem because of that! :( your second trick seems interesting though. I will try this out at home. I would really like to make one device a "slave" and be able to manage things like port forwarding only in one, so this would be optimal! – Willi Mentzel Mar 21 '16 at 15:22
  • 1
    Sweet man, good stuff – Hefewe1zen Mar 21 '16 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.