6

I wanted to load up free PSD's from TurboSquid.com, they are royalty free, and they encourage the downloads... But I CAN NOT, load them up in GIMP at all. All they show is a WHITE screen when i load it into gimp. I have GIMP v2.8.16, and I have tried to drag and drop, or manually load, or open with on the file itself. Nothing seems to actually want to open it up nothing... any help would be appreciated.

  • no hidden layers or anything? Tried running gimp in a terminal & watch for errors, especially with -c, --console-messages? – Xen2050 Mar 21 '16 at 3:57
  • Nope no hidden layers, or anything. Oddly I did run it in a terminal, and it jut blazed by no errors, it sees it as a good file, no corruptions or anything. This is a first time I have ever tried to open a PSD in GIMP, so it is new experience for me. It is weird when nothing happens. – GimpyMicGimper Mar 21 '16 at 13:31
  • Another idea - the download failed somehow, perhaps silently, still downloading a file with the correct name, but only containing text or HTML. Looked at/in it with a binary/hex editor? I'd expect some errors or some results from trying to open it in gimp though. Maybe try a newer (or older) version of Gimp? – Xen2050 Mar 21 '16 at 18:50
  • Did the re downloading, nope. Never did look at it with a binary/hex to me why would I think of doing that to a picture file...heh good idea though. Not the first thing to enter my mind. Though I didnt think of trying an older GIMP version. Since I have the newest, didnt think of going old school heh. – GimpyMicGimper Mar 22 '16 at 3:28
  • I've seen a few websites that will quietly send a short HTML page (something like "can't download this") in place of a downloaded file. Misconfigured probably, but it probably won't be the last time it happens. Also try running file on the downloaded file, maybe it's something different. – Xen2050 Mar 23 '16 at 0:52
1

Tried downloading the link you pasted, from https://www.pixelsquid.com/stock-image/square-wooden-crate-1010261998966937049?image=G02 (after checking bugmenot.com to "log in"), and it downloaded a zip file Square%20Wooden%20Crate.G02.2k.psd.zip and after unzipping Square_Wooden_Crate_01.G02.2k.psd I dragged it into GIMP and the wood crate image appeared:

crate in GIMP

It is still just one "flat" layer, with some darkening around the bottom for it's "shadow," so it's probably not much better than an image from the webpage, but it is fairly high resolution and the white background isn't extremely difficult to make transparent.

This was after I tried downloading the below plugin & copying it to GIMP's plugin directory, but I don't think it did anything. And it doesn't seem to allow the rotating that their website advertises, maybe that's what the plugin does (and probably why it's a 100MB file for an image if a crate).


I think I've found the problem... the PixelSquid website has this info (not super-easy to find, and the plugin link looks like it might be randomly generated):

Remember to install the free PixelSquid Photoshop plugin and start placing PixelSquid objects directly into your comp!

So, I think you need their special "PixelSquid Photoshop plugin" to use their files. Especially since I don't remember Photoshop or GIMP having a standard rotate feature like they describe "objects that can be placed and rotated right inside of your Photoshop comp. Just click-and-drag to find the perfect angle."

I'm not too sure if that plugin will work in GIMP...

  1. First I tried a google search for gimp use photoshop plugins. Results were inconclusive, so

  2. I just tried to download the "PixelSquid Photoshop plugin" to see if just copying it to my GIMP folder would work. Under GIMP's Preferences, in Folders -> Plug-Ins it lists /home/user/.gimp-2.8/plug-ins and /usr/lib/gimp/2.0/plug-ins so I was going to try one of those.

    However, problems include:

    1. Have to go to adobe.com to download it, which requires an email & login & password.

    2. After jumping through those hoops, it then tells me:

      Congratulations!
      Add-on acquired

      Thanks for using Adobe Add-ons!
      Follow these steps to get started:

      1. You need to install the Creative Cloud app in order to install this Add-on

      2. Click "Get Creative Cloud App"
        Install a compatible app, if needed, and make sure to Sync files to Creative Cloud

      3. Turn on Files Sync when you've installed Creative Cloud app, your Add-on(s) will be automatically installed

    3. Then it wants me to install the "Adobe Creative Cloud desktop application". I'm not even sure if that's for Windows only (likely), and it's download page won't even load on a near-recent firefox (maybe it's the ad-blocking)

--> Took another look on the plugin's page, and near the bottom there's a "Trouble installing?" section, there's a "Download (this plugin) using Extension Manager >" link, where the actual plugin can be downlaoded, so FINALLY got it downloaded. And avoided the "Adobe Creative Cloud desktop application".

BUT, it may require another program/plugin, the actual "Extension manager CC" to install it. It's supposed to be here: Adobe Extension Manager CC.

From GIMP's help on plugins it looks like GIMP's plugins are plain scripts or compile-able programs, probably more than a little different from plain PhotoShop plugins. And my Linux's file doesn't even know what the plugin is, aside from data. With a hex editor it looks almost completely random, as if it were encrypted or something... maybe it is, with all the trouble it took just to download it, and Adobe wanting it's own program to hold my hand while using it.

I did try Tor Lillqvist's program "PSPI is a GIMP plug-in that runs 3rd-party Photoshop plug-in filters", but using Linux & WINE didn't work out for me (psp.exe.so segfault), and I'm not holding my breath that the Adobe Extension Manager CC would work any better.

At that point, I'm giving up. But at least I think I found the problem - missing the "PixelSquid Photoshop plugin". If you're using Windows you should have better luck, since on Linux it's the windows & WINE programs that are giving me trouble. So on Windows the PSPI plugin for GIMP should work, and then you can try using the PixelSquid plugin. And the "Adobe Extension Manager CC" program (plugin?) should work on Windows too...

| improve this answer | |
  • As soon as I saw this,"At that point, I'm giving up...". i got to this.. & I was like...I just laughed least I know it wasent me and i wasent goign nuts! And you are right it is hidden. sigh I do have a Win8.1 comp was trying to follow on Nixxy to my windows what you said... and it didn't work there either. it got close, It turned black instead of white... lol. But goign through all those steps... I owe you a beer man! Cause I certainly wouldn't have dont what you did. Not thought of it. Though I cant believe you got farther than i ever did a PICTURE SHOWED UP!!! – GimpyMicGimper Mar 25 '16 at 0:25
  • Well, I don't mind not be able to use the files, just kinda disappointing is all. Oh well, I still appreciate you giving me info that I would never have even thought of and the help you have given me... so you have been a HUGE HELP throughout all this! Thank you so much! And your patience as well! I appreciate it a lot. Hope you have a great day. – GimpyMicGimper Mar 25 '16 at 0:28
  • Getting the flat image to appear was actually the easy part, and it does work with a plain GIMP (version 2.8.10). I may take another look at the "GIMP use photoshop plugins" problem since that sounds useful no matter what, I'll update if I find out anything. If the answer's useful or "good enough" (or the only one) you could click the check-mark beside it to select it as "correct", and maybe the up arrow to "vote up" it (may need 15 rep first) – Xen2050 Mar 25 '16 at 1:54
  • Ok, I actually found a PSD file that works, I guess the PSD from PSq are different in coding? Like the above maybe file encrypted to a point, prob to only work with PS? So the PSD do work perse in GIMP. This PSD is working Both on Nixxy, and Kaitlyn. Both PC's same setup/pic layers etc: i.imgur.com/kSeVKJW.png ~197MB PSD 130layers, so it is possible to open, just not with the PSq files is all. So you are not getting confused, or anything it is supposed to work, but it isnt period. I shouldnt need any other plugins since it is native to the program itself. – GimpyMicGimper Mar 25 '16 at 15:21
  • Sorry just realized after re reading this, Nixxy is my Linux Desktop, and Kaitlyn is my Windows PC, I call them by their names, it is natural to me... My bad for any confusion I caused you...and anyone else what I call my electronics. Heck even my wife gets confused sometimes so my apologies, especially with my Tablets and cellphones, lol makes it even worse but we aint going there. – GimpyMicGimper Mar 25 '16 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.