6

Now that Google is under progress to apply Material Design on its products, it'd be nice of them if they didn't use a dark background for Chrome's Incognito new tabs.

So does anyone know a way to change the background colour in Incognito tabs to white? I already tried few themes that didn't work.

Chrome is up to date, running under Windows 10 64-bit, and no specific pages on start-up.

NOTE: For the people who are suggesting, or will be suggesting, using Chrome's flags in chrome://flags/, this won't work and see it for yourselves:

https://drive.google.com/file/d/0B1HYzA7g_5t-NG1VZEY4MlpPZEU/view?usp=sharing

  • Are you talking about when you first open the incognito window? The only time I have a dark background is when it's displaying the You’ve gone incognito page. I personally like it because it's a noticeable difference from incognito and non-incognito. – DrZoo Mar 21 '16 at 16:25
  • @DrZoo On the first tab and subsequent tabs, they all show me that message with dark background. My eyes can't stand for contrast in colours. :( – Sanny Mar 21 '16 at 16:37
  • Ohhhh I understand what you mean now. I don't know of any way to change that at the moment. You could maybe try downloading a theme? I think you'll also hate the Chrome version 50 release. I believe the tabs and the initial background will the the dark color. – DrZoo Mar 21 '16 at 16:42
  • This is soo annoying. Especially when you have a lot of tabs opened, you can't quickly find which one is focused. Such a regression of usability.... – Olivier Pons Sep 5 '16 at 11:49
2

Download this theme from the Chrome Web Store and add it to Chrome; it should resolve your problem, although the message in the centre "You’ve gone incognito" will still be on a dark background.

  • Link-only answers are not quite welcome on SU. Please, edit your answer and describe a bit further how this solves OP's problem. – nKn Dec 15 '16 at 15:14
  • Hi there. Your answer may satisfy other people, thus I up-voted. However, the theme keeps a dark rectangle in the middle unlike my answer that bleaches everything, and thus I can't accept it as the perfect answer. Thank you, anyway :) – Sanny Dec 15 '16 at 19:05
1

I am currently using a self-made extension that overtakes the new tab page and replaces it with an empty HTML page based on the solution in: Change Chrome New Tab Page to local file

However, there will be a need to modify Chrome's executable files, otherwise you'll be welcomed with a pop-up message about using a developer mode extension every time you launch Chrome. This answer from Stackoverflow.com should help you in this regard yet you will have to run the batch file every time Chrome is updated.

  1. Create a folder somewhere in you computer, let's call it whitebg.
  2. Launch your favourite text editor (e.g. Notepad) and paste this piece of code:

    <html>
    <head><title></title></head>
    <body></body>
    </html>
    
  3. Save this as nwtab.html in the whitebg folder.

  4. Make a new text file and paste this:

    {
      "name": "White BG",
      "description": "Bleaches New Tab's Background, Including Incognito's",
      "version": "0.1",
      "incognito": "split",
      "chrome_url_overrides": {
        "newtab": "nwtab.html"
      },
      "manifest_version": 2
    }
    
    1. Save this as manifest.json in the whitebg folder.
    2. Now switch to Chrome and open the Extensions page: chrome://extensions/
    3. From the top of the page, tick Developer mode.
    4. Click the button Load unpacked extension..., and choose the folder whitebg.
    5. A new extension should appear as White BG.
    6. Finally, under our new extension, tick its Allow in incognito.
  • Hello #Sanny, What do I need to do to only change the page in incognito mode? – Tmc Jul 31 '17 at 16:54
  • @Tmc Hi there! What change you want to do? If you're asking something different than the thread/ question here, kindly make a new one so I can answer there and you may get answers from other people :) – Sanny Jul 31 '17 at 19:58
  • If I follow the steps all described above, I will change the two "new tab" pages in normal and incognito mode. What I intended was just to change in incognito mode. It's possible? – Tmc Aug 1 '17 at 13:20
  • @Tmc I'm afraid you can't. Incognito follows the normal mode; so I'm basically changing the normal mode's New page and extending this effect on incognito's New page. Hence I suggest you to customise the nwtab.html in my answer to the way you prefer and thus it will affect the New page in both normal and incognito modes. :) – Sanny Aug 1 '17 at 14:00
  • tank you, It is possible to know in which way it is and show in a line? I tried this but I can not jsfiddle.net/w49x9f1a – Tmc Aug 1 '17 at 14:30
1

It might be possible to patch chrome.dll, but would still have the incognito welcome text somewhere in there.

There is an easier way, inspecting with developer tools we can see that the styling comes from incognito_new_tab_theme.css.

This file is plain-text packed/concatenated in resources.pak, so we can edit it with a simple text editor (Notepad++).

  1. Find background-color (careful, make sure you found the right one, there are a few similar ones):

    html {
      background-attachment: fixed;
      background-color: $i18n{colorBackground};
      background-position: $i18n{backgroundBarDetached};
      background-repeat: $i18n{backgroundTiling};
      height: 100%;
      overflow: auto;
    }
    

    Replace the background-color value, however to not break the offset headers of the .pak file, make sure to use same number of chars:

    background-color: white;/***************/
    
  2. Find welcome box:

    /** Typography -------------------------------------------------------------- */
    \n
    .content {
      /* This is identical to the default background color. It's necessary to set it
         for the case when a theme with a background image is installed. */
      background-color: #303030;
      color: rgba(255, 255, 255, 0.7);
    ....
    

    I just replaced the background-color with display: none to completely hide it:

    display: none;/**********/
    
  • Well, your answer is good but Google is evil; once Chrome is updated you'll have to do these modification over and over since the file is nested under a folder that changes its name on every update (in Windows, the location is c:\program files (x86)\Google\Chrome\application\xx.x.xxxx.xx). I believe it's no different than the other answers in this thread but thank you for your efforts – Sanny Nov 8 '17 at 19:32
0

You can follow the guide here, fixed it. and yes very annoying.

You should go to chrome://flags/ find the Material Design in the browser’s top Chrome flag, and check the Non-Material option under it.

  • Sorry mate, it didn't work. These flags stopped working in a long time since Google decided to trash its browser with bloated irreversible "features" – Sanny Sep 16 '16 at 23:47
  • Welcome to Super User. External links can break or be unavailable, in which case your answer would not be useful. Please include the essential information within your answer and use the link for attribution and further reading. Thanks. – fixer1234 Sep 16 '16 at 23:58
  • Sanny, I updated google about half a hour before answering and noticed the change, and that's what I did and it fixed it. and I check and my chrome is up to date. – eyesky Sep 18 '16 at 9:35
  • @eyesky thanks mate for coming back. Unfortunately chrome won't change the dark incognito background even if you choose to use non material, thus this doesn't solve my issue here.. – Sanny Oct 10 '16 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.