2

My computer is dual booting windows 10 and Arch linux. Currently, if I shut down the computer from windows 10 I can use wake on lan fine when if I use it after shutting down from windows, but it does not work at all if I had last used linux. I have tried all 4 steps listed here other than rolling back the windows driver, as well as all the steps to set up WOL found here.

Does anyone have any ideas on how I can get WOL to work on both OS?

3

I am currently using WOL on Dell/HP hardware with mix of Windows and Linux OS. The only settings I enabled was in BIOS (nothing in the OS) and it just worked.

I've found the following link that does talk about some settings at the OS level, so you can verify if yours are set up correctly:

Linux

Ubuntu has a great tool that can check to see if your machine supports WoL and can enable it. Open up a terminal and install “ethtool” with the following command:

sudo apt-get install ethtool

You can check your compatibility by running:

sudo ethtool eth0

If your default interface is something else, substitute it for “eth0”.

Look for the “Supports Wake-on” section. As long as one of the letters listed is “g,” you can use magic packets for WoL. To enable this option, use the following command.

sudo ethtool -s eth0 wol g

Sending Magic Packet using an app like Fing to narrow down the MAC Address

  1. Power on your Linux OS
  2. Launch the Fingbox
  3. Scan your LAN and find the MAC/IP of the Linux box
  4. Power off Linux
  5. Use the same App to send WOL to the MAC from step 3
  • Yeah I set all of this up, as well as settings in network manager as instructed in the two links but it still won't work – Kironide Mar 22 '16 at 3:11
  • I use an android app but I have sent it from other computers before and it works on Windows just not after shutting down linux – Kironide Mar 22 '16 at 3:35
2

I also had this problem some years ago.

ifconfig showed support for WOL_MAGIC, but I could not get WOL working no matter what I tried after shutting down from Linux. The culprit was the implementation of the driver for the Realtek RTL8111E NIC. I remember browsing through the driver source code with comments from the developer about what a piece of junk the RTL8111E was. I can't remember where exactly I found this information, but I'll link to it when I find it.

Anyway, I don't know which NIC you have, but chances are this might be the problem.

  • I do have a realtek 8111 nic so that seems like it could be the problem. I have installed the latest driver and that did not fix it, do you know how you fixed the driver? – Kironide Mar 22 '16 at 17:02
  • If it's a driver issue, I'm afraid there's little you can do (except writing your own driver, but good luck with that). I ended up buying an Intel NIC instead for little over €20. – Egon Olieux Mar 22 '16 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.