0

I was about to install geoip module for iptables. Installation goes fine until I checked the module.

It says:

iptables: match "geoip" has version "libxtables.so.10", but "libxtables.so.11" is required.

I haven't found anything about this. What's the problem and solution? :)

0

Your geoip module is compiled with libxtables.so.11, but you have libxtables.so.10 in your system.

You can either update the package that provides libxtables.so.10 to new version, or install an old version of geoip module that uses old version of the library.

  • And what package provide libxtables, please? :) – Jelean Thomas Mar 22 '16 at 16:01
  • You have not provide any distribution in your question. Ubuntu has libxtables10 and libxtables11 packages as seen here and here. You can find necessary packages for other distributions similarly. – infiniteRefactor Mar 22 '16 at 19:12
  • UPDATE, now it is iptables: match "geoip" has version "libxtables.so.11", but "libxtables.so.10" is required. – Jelean Thomas Mar 28 '16 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.