1

I'm running a Linux guest (Xubuntu 15.10 64bit) in VirtualBox 5.0.16 on a Windows 10 host. For unknown reasons, when I now boot into Xubuntu the resolution is extremely high making everything very tiny. In full screen I don't have any black margins - it really is full screen, but all elements (bar, fonts, windows...) are extremely tiny.

One thing that helps is setting scale to 200%, but even then everything is smaller than normal. This is a new occurrence, and I'm not aware of any change I did - before it all worked normal.

Selecting x86 virtualization solutions in Additional Drivers makes no difference. Checking or unchecking View/Auto-scale Guest display also does not solve the issue. I have the Guest Addons installed.

My Windows resolution is 3840 x 2160, the same value is listed in the guest's display settings.

Laptop is Lenovo Ideapad Y700.

Thank you.

enter image description here

  • Will This help you at all? – NetworkKingPin Mar 29 '16 at 7:11
  • Did you try changing the resolution to Full HD 1080p inside Ubuntu? What happens then? In windowed mode it should cover about one fourth of your screen. If this works correctly and the items are the right size, go from there and increase the resolution as much as you can from the virtualbox menu, maybe the display driver that came with xubutu cannot handle UHD correctly. – user576053 Mar 29 '16 at 8:07
2
+50

Xfce which is under the hood of Xubuntu doesn't support HiDPI yet (double resolution aka Retina(c)). Things will get better if you set your DPI to 192.

To do that follow these steps:

  1. Open Settings panel (top left corner, then settings icon)

Settings

  1. Choose appearence
  2. Click on tab Fonts
  3. Set DPI equal to 192 instead of 96 Result

You would also like to enlarge your panel, set it's width twices wider than default (24 -> 48). (Settings -> Panel -> Row size)

To make Window manager titles bigger select HiDPI wm theme in Window MAnager settings (it's called Default hdpi) enter image description here

As you may have seen some elements (like ticks) are still small. That's due to obselete GUI library, GTK2.

Here you can read more about Desktop environments which support HiDPI. If you are unsatisfied with the outcome try another Desktop Environment. Personally, I recommend you to use GNOME 3 in fallback mode. To install gnome:

  1. Type in terminal sudo apt install gnome-desktop
  2. Logout
  3. In Login manager select Gnome session
  4. Log back in
  • Thank you! I just wish you posted a couple of minutes earlier - out of despair I wiped my linux and reinstalled VirtualBox. You managed to identify the problem correctly. I went for cinnamon as it seems it has the best HiDPI support (xfce with your suggestions worked too, but it looked pretty terrible). Thank you - now that I know that the issue is HiDPI I'll be on the lookout. – user152925 Mar 30 '16 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.