2

My windows 8 is installed on the C drive. I installed ubuntu on the D drive. By mistake I chose the boot loader to load from the C drive while installing ubuntu. Then, restarted and it directly booted into ubuntu without giving me the option to choose from the OS list. Then, I repaired the windows loader from ubuntu using the following command:

sudo apt-get update; sudo apt-get install syslinux

then

sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda

now, it directly boots into Windows only! The problem is reversed!

Question is how to have a boot loader option to choose from, to boot into the desired OS. Thanks

Last Update

I removed those unncessary disks and reinstalled the ubuntu. but it is the same story! I have 120GB SSD on the Port0 containing my windows 8 and a disk of 500GB in the Port1 on which I installed ubuntu and 2TB disk in Port2. Plus a USB stick of 8GB which I used to boot-repair for. Here is report uploaded to: http://paste.ubuntu.com/15503838/

By the way, I can reinstall the ubuntu, if need be, or if an easier solution can be found by doing so. But unfortunately i can't touch the windows OS.
I spent all my day on this boot issue, but no success, this is so complicated for me only when it comes to separate harddrives, I have it running on my laptop, on one drive which has two partitions. Working like a charm! But since the desktop has multiple hard drives, it gets complicated. I would appreciate your help on this.

  • help.ubuntu.com/community/Boot-Repair – Moab Mar 23 '16 at 22:28
  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Mar 24 '16 at 0:09
  • @RodSmith i think you missed the point when I said that I don't have access to ubuntu anymore, I don't have the option to log into ubuntu to run this command. – cplus Mar 24 '16 at 1:01
  • @RodSmith I added the boot info pastebin link. Please help on this. – cplus Mar 24 '16 at 6:31
  • Try either mozexty's or Tom Yan's suggestions; either might work. That said, your setup is unusually complex, just because you've got so many disks -- that could easily confuse just about any repair tool or script. – Rod Smith Mar 25 '16 at 13:07
1

Well apparently your Ubuntu is installed on a separate disk (sdg), and since you picked the Windows disk (sda I assume), the boot code of grub is installed to its MBR, and then you replaced it with syslinux's boot code. which look for active partition and end up loading bootmgr.

So you need to reinstall grub on sdg (with Ubuntu live medium):

mount /dev/sdg1 /mnt
grub-install --boot-directory /mnt/boot /dev/sdg

You can just leave the Windows drive as the prioritized drive in your BIOS and switch to Ubuntu with your BIOS boot menu when desired.

If you prefer to use grub to switch between, prioritize the Ubuntu drive in BIOS setting, and add boot entry for the Windows:

GRUB_DISABLE_OS_PROBER=true

This entry is used to prevent GRUB from adding the results of os-prober to the menu. A value of "true" disables the os-prober check of other partitions for operating systems, including Windows, Linux, OSX and Hurd, during execution of the update-grub command.

(https://help.ubuntu.com/community/Grub2/Setup)

So make sure the option is false in /etc/default/grub, make sure os-prober is installed with apt-get, and then run update-grub.

  • I updated the question, first by disconnecting my external drives which made the report so long, and did a boot-report and uploaded a new boot repair report. Please help me solve this problem which wasted whole my day on this. I can't understand the boot issues easily. It is a bit complicated for me. – cplus Mar 26 '16 at 0:06
  • I added the line enabling the os prober, but no success! and then added a menuentry to chainload windows efi, but says it can't find the efi file! I am stuck! what are my options now? – cplus Mar 26 '16 at 1:53
  • @Mpondomise of course it won't work now. SInce you reinstalled Ubuntu(/grub) in UEFI mode while your Windows' are installed in BIOS mode. Either reinstall Ubuntu in BIOS mode or use rEFInd instead of grub, since grub EFI cannot chainload BIOS version of Windows Boot Manager. I have no idea about shim or whatsoever btw since I always disable Secure Boot. – Tom Yan Mar 26 '16 at 8:56
  • 1
    To elaborate on Tom Yan's last comment, you could install rEFInd (use the PPA described here and edit /boot/efi/EFI/refind/refind.conf: Uncomment the scanfor line and add hdbios to it. This should enable rEFInd to either boot Ubuntu or chainload to your BIOS-mode Windows. This is an overly-complex solution, though; it's better to get GRUB working in BIOS mode. Boot Repair, as suggested by mozexty, should be able to do this -- but you must boot the repair tool in BIOS mode. – Rod Smith Mar 26 '16 at 16:17
1

I've just used Boot Repair with success. Just download the live CD or Live USB, and boot your machine with it.

enter image description here

  • I added the pastebin link – cplus Mar 24 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.