4

The title bar, menu bar and some fonts applications (such as Quickbooks, Microsoft Onedrive) get so small that the words get cut off vertically and very difficult to read.

I searched online and tried using a regedit hack to change the size, and also altering the Advanced Display Setting in control panel but none of them worked.

Shrunk fonts in Windows 10
click to enlarge

Any idea why this is happening? How can I correct the size, along with the containers around the small titlebar/menubar text?

5

One possible reason is because you're using a high DPI screen.

When programs run, Windows says "hey, are you high DPI aware?". If a program says "no", then Windows handles the scaling to ensure that they aren't microscopic. If a program says "yes", then Windows lets the program do the scaling.

Unfortunately a number of programs incorrectly say "yes" (when they actually mean "no") and, as a result, end up being displayed extremely small.

Previously you needed to change a registry setting and use manifest files to resolve this - however in the latest version of Windows you can now right click on the executable, select properties and override the DPI setting:

enter image description here

The options are:

  • Application - The default setting, scale only if a program reports itself as not high DPI aware.
  • System - Windows will stretch the UI, this will cause all text and graphics to become blurry.
  • System (enhanced) - Only works with certain (GDI) programs but will scale programs whilst reducing the amount of blurring.

My recommendation would be to always try "System (enhanced)" first and fall back to "System" if that doesn't work.

1
  • Should be an accepted answer (for one of the scenarios covered by the OP). – BobHy Jul 22 '19 at 13:19
0

On another question, i found a probably useful answer. It shows two different methods to change font sizes. Please give feedback if one of these worked for you.

https://superuser.com/a/951206/574050

3
  • 3
    This is not an answer. Don't expect positive feedback for just sharing a link. – Aaron Gillion Mar 23 '16 at 23:46
  • @AaronGillion I know but i cant comment yet, because i just joined the community yesterday and my rep isn't high enough. – PhoenixHell Mar 23 '16 at 23:53
  • Phoe thanks for replying but like I said on the post I tried altering the setting from display setting already, the size stays the same... – Jacky Kwan Mar 24 '16 at 16:26
0

Recently, we had a Surface Pro 3 exhibit some weird behavior with menu fonts (all other fonts were okay, only menu fonts). What is even more weird was the thing that "fixed" it.

The symptoms was precisely as follows:

  1. System operating fine all the way until Windows 10 1703 Creators Update
  2. After which, the menu fonts appeared incredibly small
  3. Whenever the PC was reboot, the first app run, would show normal menu font, then, the subsequent app launched (be it same or different) would yield microscopic menu fonts (I estimate it was half the font size compared to everything else). Even popup font for right click on Windows start was affected.

I tried registry hacks to the Windows Metrics as well as setting the Windows DPI to a higher level, but, the weird behavior described in step 3 persisted.

I found a bizarre solution to the problem:

  1. Open Control Panel
  2. Open Region control panel
    • If View by: category:
      • Click Clock, Language and Region
      • Click Region
    • If View by: Small icons Large icons
      • Click Region
  3. Select Administrative tab
  4. Language for non-Unicode programs > Click Change system locale ...
  5. For me, it was set to English (Australia), change it to another language, say, Chinese (Simplified)
  6. Reboot
  7. Note the menu fonts now display normally for all apps

As to why we had this font problem and as to why the above fixes it, I have no idea. I was just randomly troubleshooting the problem and accidentally stumbled upon this fix. Just for further troubleshooting, I changed the locale back to English (Australian) and even English (United States), and the problem returned.

enter image description here

0

I had this problem only on some isolated cases. E.g. Netflix UWP app version: 6.93.375. It went OK after resetting the app: right click on its launcher > More > App settings > Reset.

Not the answer you're looking for? Browse other questions tagged or ask your own question.