0

First of all i wanna say to you that i already connected the routers (LAN-TO-WAN) ... But i have issues and questions :) ...

My primary router and my secondary router both also using DHCP... why?

Because the wireless signal of my primary router is poor... and is little far... so the adventage is my secondary router which is more close to me...

So i wanna ask is it possible the routers to be connected lan to wan just as they are... but both to use DHCP and both to have wifi ... which means when i search of nearly wifi's i should have 2 wifis for example the wifi from the router 1 and the wifi from the router 2...

Ok i made that too somehow... now the thing is that ... THIS 2 WIFI'S ONLY WORK WHEN BOTH OF THE ROUTERS USING DHCP (which means i can connect on the both without any problem) so the real thing is if i disable the DHCP from the secondary router and trying to use again same 2 wifi's then there is problem (When i try to connect on the secondary wifi it's connecting but it's saying "getting ip adress for a too long time.. and again at the end nothing... no internet.. (Of course if i try to connect on the primary wifi i will have internet , i am able i've tried)...

Is there anyway to make this work but the DHCP of the second router to be disabled (WITHOUT BRIDGING BECAUSE BRIDGING I ALREADY TRIED AND DIDN'T HELP ME)

OK I'LL SUGGEST ANOTHER IDEA... WHAT IF I DISABLE THE WIFI FROM MY PRIMARY ROUTER WHERE THE DHCP NORMALY SHOULD BE ENABLED, AND USE ONLY THE WIFI FROM MY SECOND ROUTER (because it's stronger signal) but the DHCP of the second router to be disabled ????

I tried also this but it didn't work... it's still saying "getting ip adress" (i see that cuz i connect from the mobile, no matter from where , i can't get it successful. ANY HELPPP ???

AND ALSO ANOTHER THING...

HOW CAN I SHARE A HOMEGROUP WITH ALL THE DEVICES CONNECTED TO MY NETWORK (FROM THE FIRST AND SECOND ROUTER)...

BECAUSE ONLY MY PC IS CONNECTED TO MY SECOND ROUTER, AND ALL OTHER THINGS LIKE TV, AVR-RECIEVER FOR MUSIC, LAPTOP ARE CONNECTED ON MY PRIMARY ROUTER,

So the interesting thing is that, when i want to create homegroup, my pc or my laptop cannot find each other, is that because they are not on the same router?

I mean even if is that, i connected the routers so whats the problem now? How to fix everything this guys....

THANKS SO MUCH WHOEVER HELPS!!!

  • 1
    Please don't use all-caps, and please use bold formatting sparingly. Your question really reads like shouting. – bwDraco Dec 19 '16 at 21:21
2

The problem is you have two separate networks and are not routing correctly between them, if you have no technical need for two distinct broadcast domains, then the correct way to do this is to make one large subnet.

First go into the secondary router, if your primary router is 192.168.1.1, set the secondary router as 192.168.1.2, and turn off it's DHCP service. Log into the primary router and make sure it's DHCP range does not include 192.168.1.2. Now connect the cable you have from a LAN port on primary router to a LAN port of the secondary router. Connect a PC to the secondary router by either a cable or wirelessly, and release/renew your IP address. You should be all set. This will fix all of your issues and allow the homegroup, sharing, and everything else to work properly.

  • How should i renew my ip? And how do i know if the DHCP of my primary router includes the 192.168.1.2 ? – AlArgos Mar 24 '16 at 10:35
  • Depends on your operating system, in Windows use ipconfig /release then ipconfig /renew, but a reboot works in all cases. In your primary router look at DHCP start address or DHCP range and adjust if needed, most likely the default settings are OK anyway. – acejavelin Mar 24 '16 at 11:04
  • I can't belive that was so f*cking simple ... :/ I tried before ... i missed something 100% :D Thanks so much!!! – AlArgos Mar 24 '16 at 13:19
  • Some routers have DHCP forwarders, if yours does, make sure it's pointing at 192.168.1.1. Some devices might have issues getting an IP otherwise. If there's no forwarding option, you're probably fine. Also, you should consider turning the firewall and routing services off on the second router, if you can. It's acting as an AP, so it doesn't need them. Finally, make sure you also point the secondary router (the AP) at 192.168.1.1 as its default gateway. That way it can still do it's own thing, like checking the time and for updates (if that's supported). – MagnaVis Oct 16 '16 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.