Up front: I'm using windows 7 64 bit.

So sometimes I am trying to kill a process but it won't quit. I can try killing the process or the process structure, but Task Manager won't accomplish anything. There are a couple of tricks on the net, like

taskkill.exe /f /fi "status eq not responding"

but I wouldn't be asking here if that did the job...

Is there any trick to get rid of these processes completely?

The reason I'm dealing with this is because I sometimes run a program that won't start properly and starts a bunch of helper programs, but none of the helper programs show up the processes, so I figured that just killing the processes that are visibly active would do the trick, though seemingly they are jammed.

Thanks to a few users I have tried resolving the issue by using Process Explorer and closing the handle/killing the process. This did not work either. If you have any other suggestions I'll be happy to hear them.

  • 1
    It's really dead, you're just seeing the corpse. See How to kill a task that is "lacking an instance"?
    – Ben N
    Mar 24, 2016 at 14:06
  • 1
    As mentioned in the post that @BenN posted, download and use Process Explorer to kill the process, close open handles to it.
    – Ganesh R.
    Mar 24, 2016 at 14:49
  • @BenN Thanks for your reply. I was hopeful but this did not resolve the issue either......
    – 1010011010
    Mar 24, 2016 at 15:19
  • Hmm, interesting. Sounds like you have a hung kernel-mode driver. This article might help you debug, if you're up for some serious troubleshooting. Does the problem happen with many different programs, or just a couple? If the latter, which programs? (I've retracted my close vote.)
    – Ben N
    Mar 24, 2016 at 15:49
  • 1
    It only happens with one program, it's a video game "League of Legends". When I open the first instance, after opening it, subsequent instances will produce new processes but won't no there is no new visual output. I've contacted their customer support but up until now I'm only getting automated responses which don't seem to help..
    – 1010011010
    Mar 24, 2016 at 16:29

1 Answer 1


You can try using Process Hacker - http://processhacker.sourceforge.net. I've been using it a long time and it always worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.