6

On my Windows 10 I am using 3 different keyboard layouts. Whenever I type something in some application the operating system is matching the proofing language for spelling and grammar check with the language of the keyboard layout in use: for example, when I am using the ENG keyboard layout then English is used as proofing language.

It's often the case though that I am using the keyboard layout of my physical keyboard, even when I am writing in a language different from the one of the keyboard.

How do I tell the operating system, to use a specific language for proofing, regardless the keyboard layout?

2
  • @BožoStojković my question is about Windows, not OneNote. – Marco Lackovic Aug 11 '20 at 7:06
  • Oh sorry, my mistake – Božo Stojković Aug 11 '20 at 7:55
6
  1. Go to settings > Region & Language.
  2. In "Languages" > Add a language.
  3. Add the language that you want to use for language proofing.
  4. Click on that new added language and hit "options".
  5. Add the keyboard layout that you want.
  6. Switch proofing languages with AltShift.
4
  • It does not seem to answer the question on how to set the proofing language regardless the keyboard layout – Marco Lackovic Aug 22 '16 at 10:13
  • In fact it is the answer, I'm showing how to have any keyboard layout and a different proofing language. – Andrés Ruiz Aug 24 '16 at 2:34
  • Alt+shift switches both keyboard layout and proofing language. I do not want to switch keyboard layout. That's why it is specified "regardless of the keyboard layout". – Marco Lackovic Aug 24 '16 at 11:00
  • 2
    Let me explain, my problem is that I've a ENG keyboard but most of the time I write in Spanish, but sometimes (like right now) I write in English. So I had one language (Eng) installed with my English keyboard, so when I write in Spanish everything is marked as spelling error. Then what I did was add Spanish to windows itself in [ settings > Region & Language ] and for that new language I added the English (UE International) language. Now I've two proofing languages with the same keyboard layout, I really think it solves your problem. – Andrés Ruiz Aug 25 '16 at 21:58
0

Go to settings > Region & Language.

In "Keyboard and Languages" > click Change Keyboard.

Click "Add" Button

click the "+ button for the language that you want to spell check in".

Then Click "+ keyboard"

Now "+ Show More" option tick button

Select the keyboard you have.

Now click "ok" and you are done.

You can then also move you alternate keyboard language up into default position by clicking on it and clicking "Move Up".

so you could have English language with Spanish keyboard or vice versa.

Hope this helps FYI I was in win 7 Thanks

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.