0

I have got a strange problem, my video card is a Nvidia gtx 970 right now using Nouveau display driver, if I use proprietary driver by Nvidia everything works until the pc goes in the sleep state, when I "wake" it up it tells me there is no network available (I only use wired connection), but this doesn't happen if I use open source drivers... The only problem with open source drivers is that all the videos on the web flicker which didn't happen while using proprietary. Is there a way to fix all this mess? Thank you

I ran the inix -Fand this is what I got:

neil@Balthasar:~$ inxi -F
System: Host: Balthasar Kernel: 4.2.0-34-generic x86_64 (64 bit)
Desktop: Xfce 4.12.3 Distro: Ubuntu 15.10 wily
Machine: Mobo: Gigabyte model: Z97X-Gaming 7 v: x.x
Bios: American Megatrends v: F6 date: 05/30/2014
CPU: Quad core Intel Core i7-4790K (-HT-MCP-) cache: 8192 KB
clock speeds: max: 4400 MHz 1: 4379 MHz 2: 4116 MHz 3: 4388 MHz
4: 4340 MHz 5: 4400 MHz 6: 4400 MHz 7: 4376 MHz 8: 4400 MHz
Graphics: Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Card-2: NVIDIA GM204 [GeForce GTX 970]
Display Server: X.Org 1.17.2 drivers: (unloaded: fbdev,vesa)
FAILED: intel,nouveau
Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)
GLX Version: 3.0 Mesa 11.0.2
Audio: Card-1 NVIDIA GM204 High Definition Audio Controller
driver: snd_hda_intel
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
Controller
driver: snd_hda_intel
Card-3 Intel 9 Series Family HD Audio Controller
driver: snd_hda_intel
Card-4 Logitech Webcam C270
driver: USB Audio
Sound: Advanced Linux Sound Architecture v: k4.2.0-34-generic
Network: Card: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
driver: alx
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: Drives: HDD Total Size: 280.1GB (8.8% used)
ID-1: /dev/sda model: Samsung_SSD_840 size: 120.0GB
ID-2: /dev/sdb model: Hitachi_HTS54161 size: 160.0GB
Partition: ID-1: / size: 46G used: 5.0G (12%) fs: ext4 dev: /dev/sdb5
ID-2: /home size: 74G used: 3.9G (6%) fs: ext4 dev: /dev/sdb6
ID-3: /tmp size: 13G used: 33M (1%) fs: ext4 dev: /dev/sdb7
ID-4: swap-1 size: 16.00GB used: 0.01GB (0%) fs: swap dev: /dev/sdb1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 227 Uptime: 2 days Memory: 2406.6/7829.7MB
Client: Shell (bash) inxi: 2.2.16

  • Not really sure what the video driver would have to with the networking not working... Could you add what kernel and specific distro version, and the output of inxi -G and inxi -n, or maybe even inxi -F so we can see what hardware you are talking about? If your distro gives an error, try installing inxi with sudo apt-get install inxi first. Thanks. – acejavelin Mar 24 '16 at 17:13
  • I did as you told me and I posted the result in the question – OverMorrow Mar 24 '16 at 19:41
  • Thanks, unfortunately I don't see any red flags that jump out at me, sorry, but I am not familiar with the specifics of some of your hardware. – acejavelin Mar 24 '16 at 19:47
  • Thank you anyway, I hope there is someone who can help me sooner or later... – OverMorrow Mar 24 '16 at 22:01
2

I suggest you trying latest version of drivers and xfwm.

Fisrtsly xfwm4. After release of 4.12.3 main developer has pushed a lot of commits. Now xfwm4 relies upon glx backend, which fix tearing and may fix problems with your gpu. To do this follow these instructions:

  1. Install dependencies for building xfwm4 sudo apt-get build-dep xfwm4
  2. Install extra dependencies and git sudo apt-get install git libepoxy0 libepoxy-dev
  3. Clone form git git clone http://git.xfce.org/xfce/xfwm4
  4. cd xfwm4
  5. ./autogen.sh
  6. make
  7. sudo make install ( If you would like to install a package run sudo checkinstall)

Now run xfwm4 --replace and test whether everything is OK.

The second thing you may try to do is to wait until release of kernel 4.6 which will enable HW acceleration on latest Nvidia Maxwell generation

And the last - try installing latest beta Nvidia driver version 364. If you were using before driver with version lower than 361, try latest stable driver from this ppa ppa:graphics-drivers/ppa

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.