2

In my installation there is no Safe Remove icon in the system tray. It is not hidden, simply there is no such icon. (I checked in "Notifications & actions" and there is no such icon in the list, and even switched on "Always show all icons...",) no traces...

I have two USB drives plugged in... Both drive's policy is set to "Best performance" and not "Quick removal"

There is no eject in the context menu when I right click on them.

EDIT:

enter image description here

  • Do you see the drives in "Devices and Printers" (not "Device Manager"): ptpb.pw/rrdZ.PNG ; If so can you attach a screenshot like mine? (Double click on them and switch to the "Hardware" tab) – Tom Yan Mar 24 '16 at 18:55
  • See my edit, added picture – g.pickardou Mar 24 '16 at 20:41
  • Can you check what's the Removal policy of the USB Mass Storage Device listed there? : ptpb.pw/KkAD.PNG ; Also, is the drive connected directly to a USB port on the motherboard or is there any hub or so in between? – Tom Yan Mar 24 '16 at 20:58
  • Btw, it's normal that you don't see "Eject" when you right click on it, because it's probably a Basic disk (typical for portable HDD) instead of a Removable disk (typical for thumb drive), but that doesn't affect whether it shows up with the icon. Also, it doesn't really matter whether you pick Quick removal or Better performance either. – Tom Yan Mar 24 '16 at 21:08
  • Apart from Removal policy, also check Safe removal required. – Tom Yan Mar 24 '16 at 21:17
0

Try this article here, it's pretty explanatory

TL;DR:
beside the obvious hidden notification selection that you mentioned,

  • try: winLKey+R and run this command rundll32.exe shell32.dll,Control_RunDLL hotplug.dll
  • Open My Computer ->Right click on the USBdrive->Properties->Hardware tab and select the removable drive from the list ->Click the Properties button ->Click on the Policies tab->Change the option from “Optimize for quick removal” to “Optimize for performance” ->press OK.
  • try USB Disk Ejector
| improve this answer | |
  • Thanks. I've read that already. Also I wrote in my question in advance "Both drive's policy is set to 'Best performance' and not 'Quick removal'" – g.pickardou Mar 24 '16 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.