4

I am trying to debug the kernel of a windows 7 virtual machine and am following the steps here, here and here.

I ran:

bcdedit /debug on
bcdedit /dbgsettings serial debugport:n baudrate:115200 

on the virtual machine and have set up the port to a named pipe:

serial port setup

but when I reboot the machine I get:

serial pipe error

How can I create the pipe inside the guest machine (both the host and the guest are running windows 7)?

4

You set Host pipe. It means you need to fill pipe name like this: \.\pipe\VirtualMachineName

Moreover, as Robin Hood mentioned you need to uncheck Connect to existing pipe/socket it helps don't create a pipe manually. After launch Virtual machine you can check created pipe via pipelist application. You should see VirtualMachineName on the list.

C:\Windows\system32>pipelist64.exe
...
pipe_returnb2848f45-49cf-444b-85a1-04af7fe5606e          1              128
mojo.9004.8732.10216662671524970515                      1                1
mojo.9004.9560.12163195199288806074                      1                1
mojo.9004.9560.2084235546261883787                       1                1
VirtualMachineName                                       1                1

You can read what is pipe here. A pipe isn't a simple file.

2

it is not an existing port, uncheck connect to existing pipe, so it creates a new one.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.