7

I upgraded laptop Toshiba M5 with NVIDIA GeForce 8600 GT video card to Windows 7 32 Ultimate , but the Sleep mode option is disabled on the Shut Down menu (visible, but disabled). I checked the available Power options, but I couldn't see a setting for enabling the Sleep mode. I checked the device manager and all drivers are working normally.
I would like to ask what else I can do in order to enable the Sleep mode.

7

It can also be your display drivers. Open an admin mode cmd and do:

powercfg -a

If it complains about VGAPNP.SYS, you have your prime suspect right there.

3
  • Yes, I get this message The VGAPNP.SYS display driver does not support standby. But how do solve this issue? Sep 6 '12 at 12:46
  • You need a display driver that supports it :/ You'll have to look for them, but maybe there is no suitable driver for your machine
    – Victor
    Sep 11 '12 at 10:20
  • I have the same issue but powercgf -a does not report any obstacles. It just says that S3 is disabled by current energy policy. Duh! Any other ideas? Dec 11 '12 at 16:46
1

It could be an issue with the Multimedia settings. Go to the "Power Options" control panel and underneath the active power plan, select "Change Plan Settings". From there, click "Change advanced power settings". From there, find the node "Multimedia Settings" >> "When sharing media" and from there select "Allow the computer to sleep" for the "On battery" and/or "Plugged in" states.

Media center apparently will disable sleep when it thinks that media is being shared.

1
  • 2
    Hmm, I have the same problem, but this suggestion does not solve it for my case.
    – Bernhard
    May 28 '12 at 12:32
0

I was able to resolve the issue for my Lenovo ThinkPad T420 by installing this driver. Now sleep/standby works just fine on my TP.

0

To enable Sleep (suspend), Hibernate, etc, run powercfg -a.

If you get the error vgapnp.sys dipslay driver does not support sleep, this is likely because your computer is using the default Windows driver for your GPU (display adapter). This may also show up as the screen being stretched, and/or a error in the device manager:

enter image description here

To solve this, install the appropriate third party driver (sort of said here in the support article/) - for Intel try here, NVidia here, and AMD here. If your computer is a prebuilt machine (e.g. laptop), you can also try the manufacturer's website as they may have their own versions of the drivers. Once installed and rebooted, provided the installed GPU drivers support it, powercfg -a should show that Sleep etc are now supported, and those options should appear in the power menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy